2

I want to show only a part of my cited bibliography. In my MWE, I cited three references, but when calling my bibliography at the end of the document I just want to show the first reference of my bibliography. In other words, I need to cite three references and only display one of those three. I need this because it is an exposition and I need to talk about just a small part of the cited bibliography.

This is the code

\documentclass{beamer}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{key,
  author = {Author, A.},
  year = {2001},
  title = {Title},
  publisher = {Publisher},
}
@article{angulo2015dynamics,
  title={Dynamics and forecast in a simple model of sustainable development for rural populations},
  author={Angulo, David and Angulo, Fabiola and Olivar, Gerard},
  journal={Bulletin of mathematical biology},
  volume={77},
  number={2},
  pages={368--389},
  year={2015},
  publisher={Springer}
}
@book{david,
Author = {Angulo García, David and Olivar Tost, Gerard},
Publisher = {Manizales, 2012.},
Title = {Esquemas de Desarrollo Sostenible : una Aplicación de Redes Complejas a la Región de Caldas = Sustainable development schemes: [recurso electrónico].},
URL = {http://ezproxy.unal.edu.co/login?url=http://search.ebscohost.com/login.aspx?direct=true&db=cat02704a&AN=unc.000723149&lang=es&site=eds-live},
Year = {2012},
}
\end{filecontents}
\begin{document}
\begin{frame}{Justificación}

\footnotemark
\setcounter{footnote}{1} 
  \footnotetext{\cite{key}, \textsuperscript{2}\cite{angulo2015dynamics}, \cite{david}} 
\end{frame}

\begin{frame}[allowframebreaks]
    \frametitle{Referencias}
    \bibliographystyle{amsalpha}
    \bibliography{\jobname}
\end{frame}
\end{document
  • Would switching to biblatex be an option for you? This has the nice refsection mechanism, which would make this really easy – user36296 Nov 20 '18 at 9:24
  • @samcarter How is the procedure for switching to biblatex? – JuanMuñoz Nov 20 '18 at 16:19
  • I added a short example below. The main difference is that it needs to be compiled with biber instead of bibtex – user36296 Nov 20 '18 at 16:31
  • tex.stackexchange.com/questions/5091/… is a guide how to switch from bibtex to biblatex – user36296 Nov 20 '18 at 16:34
2

With biblatex one could use a \refsection around your bibliography and add only the entries you'd like to cite with \nocite.

\documentclass{beamer}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{key,
  author = {Author, A.},
  year = {2001},
  title = {Title},
  publisher = {Publisher},
}
@article{angulo2015dynamics,
  title={Dynamics and forecast in a simple model of sustainable development for rural populations},
  author={Angulo, David and Angulo, Fabiola and Olivar, Gerard},
  journal={Bulletin of mathematical biology},
  volume={77},
  number={2},
  pages={368--389},
  year={2015},
  publisher={Springer}
}
@book{david,
Author = {Angulo García, David and Olivar Tost, Gerard},
Publisher = {Manizales, 2012.},
Title = {Esquemas de Desarrollo Sostenible : una Aplicación de Redes Complejas a la Región de Caldas = Sustainable development schemes: [recurso electrónico].},
URL = {http://ezproxy.unal.edu.co/login?url=http://search.ebscohost.com/login.aspx?direct=true&db=cat02704a&AN=unc.000723149&lang=es&site=eds-live},
Year = {2012},
}
\end{filecontents}

\usepackage[style=alphabetic]{biblatex}
\setbeamertemplate{bibliography item}{\insertbiblabel}
\addbibresource{\jobname}

\begin{document}
\begin{frame}{Justificación}

\footnotemark
\setcounter{footnote}{1} 
  \footnotetext{\cite{key}, \textsuperscript{2}\cite{angulo2015dynamics}, \cite{david}} 
\end{frame}

\begin{frame}[allowframebreaks]
    \frametitle{Referencias}
    \begin{refsection}
    \nocite{key}
    \printbibliography
    \end{refsection}
\end{frame}
\end{document}

enter image description here

  • Are you sure the code is working? An error message is shown, It says that all the references are undefined – JuanMuñoz Nov 29 '18 at 2:13
  • @JuanMuñoz Yes, I'm sure the code is working. Did you run biber? – user36296 Nov 29 '18 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.