2

enter image description hereIn an interlinear translation (Yiddish left side - German right side) I have footnotes, which unfortunately mess up the line spacing. What can I do to make this distance go away?

compiling with xelatex

    % arara: xelatex

   \documentclass[10pt,a5paper,twoside]{scrbook}
   \usepackage[onehalfspacing]{setspace}

   \usepackage[bmargin=2.25cm]{geometry}



   \usepackage{scrpage2}
   \pagestyle{scrheadings}
   \clearscrheadfoot

   \ihead{\headmark}
   %\automark[chapter]{chapter}
   %\automark*[section]{}

   \ohead{\pagemark}
   \setheadsepline{0.4pt}
   \setkomafont{pageheadfoot}{\normalfont\normalcolor\small}\setkomafont{pagenumber}{\normalfont}

   %Formatierung der Kopfzeilen:
   \addtokomafont{pagehead}{\normalfont}


   \setkomafont{disposition}{\normalcolor\bfseries} %Schrift in Überschriften, Inhaltsverzeichnis

   \clubpenalty=10000
   \widowpenalty=10000

   \usepackage[parfill]{parskip}
   \usepackage[series={A,B,C}]{reledmac}
   \usepackage{reledpar}



   %%%\Xendnumberonlyfirstinline

   \Xendbeforepagenumber{S.\,}
   \Xendafterpagenumber{:\,}
   \Xendlineprefixsingle{Z.\,}

   \setgoalfraction{0.85}


   \lineation{section}
   \linenummargin{left}%%right für Zeilennummern rechts
   %\setRlineflag{}



   \linenumincrement*{5}
   \firstlinenum*{0} %Zahl hochsetzen, um Titelei unnummeriert zu haben

   \maxchunks{10000}

   \usepackage{color}
   \usepackage{multicol,multirow, bigdelim}%%times RAUS





   \usepackage{amsmath}
   \usepackage{fontspec}
   \usepackage{polyglossia, xunicode}
   \usepackage{libertine}
   \setmainfont[Ligatures=TeX]{Linux Libertine}%Linux Libertine O %%EzraSIL hat keine kursiva

   \setmainlanguage{german}
   \setotherlanguage{hebrew}
   \newfontfamily\hebrewfont[Script=Hebrew]{EzraSIL}



   \setmainlanguage{german}
   \setotherlanguage{hebrew}


   \newfontfamily\hebrewfont[Script=Hebrew]{Arial}



   \newcommand\einzugjid{\hangindent=5mm\hangafter=1}

   \newcommand\speaker[1]{\noindent{#1} \einzugjid
   }

   \newcommand\einzug{\hangindent=5mm\hangafter=1}

   \newcommand\speakerd[1]{\noindent
   {\textsc{#1}} \einzug
   }

   \usepackage[normalem]{ulem}



   \begin{document}



   \begin{pages}
   \begin{Leftside}
    \setRTL
    \beginnumbering


\pstart {\texthebrew{\speaker{שלמה.}
איהר\RTLfootnote[3]{האָן איהר}
 נעבעיונגע מער לעססע אייך אַהן {לֵיצים}  דוֹא, דען קענט איהר אייך דערווייל לושטיג מאַכע, ביס מיר געססע האָן. {(}{אַב}{)} {(}{אונטער ווילדעם  געפאָלטער אַללע אַב ביס אויף גומפלכען}{)}
}}

\pend

        \endnumbering
   \end{Leftside}


   \begin{Rightside}

   \beginnumbering


  \pstart \speakerd{Schlaumeche.} Ihr\footnote[3]{hai} \textit{Nebenjungen},wir lassen euch einen  leisen Ton da, dann könnt ihr derweil lustig sein, bis wir gegessen haben. \textit{(Ab.)} \textit{(Unter wildem Gepolter alle ab bis auf Gumpelchen.)} \pend

   \endnumbering

   \end{Rightside}
   \end{pages}
   \Pages



   \end{document}
  • you should use \Afootnote specific to reledmac/reledpar. – Maïeul Nov 24 '18 at 17:47
  • @Maïeul: thank you. but this doesn't work either (then I have just no footnote). – לאה פּאַסטעך Nov 24 '18 at 19:25
  • sorry, it was \footnoteA (\Afootnote is for critical footnote) – Maïeul Nov 24 '18 at 21:04
  • Ok, this one I tried before; but it is not what I need. The problem is this: First I want to number my footnotes by myself. Second: The left page is right-aligned (Hebrew), therefore the footnote must start on the right at the bottom of the left page, while on the right page it should start on the left. – לאה פּאַסטעך Nov 25 '18 at 10:34
  • all thas thing could be set. Unfortunatly, now I have no time (RTL scripting is complex). I will try this week. Don't hesitate to send me an email next mondy if you hae no answer. – Maïeul Nov 26 '18 at 9:06
3

The problem is that footnote defined by bidi are not compatible with footnote defined by reledmac and by the way reledmac numbers/split the lines.

However, reledmac as the tool to get your goal.

General rule to set language in parallel typesetting

You must wrap side with a specific language with language environment, and not changing language environment inside.

So

 \begin{hebrew}
   \begin{Leftside}
    \beginnumbering

    \pstart \speaker{שלמה.}
    איהר\footnote[3]{האָן איהר}
    נעבעיונגע מער לעססע אייך אַהן {לֵיצים}  דוֹא, דען קענט איהר אייך דערווייל לושטיג מאַכע, ביס מיר געססע האָן. {(}{אַב}{)} {(}{אונטער ווילדעם  געפאָלטער אַללע אַב ביס אויף גומפלכען}{)}

    \pend

    \endnumbering
  \end{Leftside}
\end{hebrew}

Using reledmac footnote

You must use reledmac familiar footnote (\footnoteA, \footnoteB, etc) inside reledmac part of texts. However, older version of reledmac didn't allow to manually numbering familiar footnote. The version 2.28.0, that I have just send on CTAN, allows it. So you should wait few day and upgrade your TeXLive/Miktex packages.

So

\pstart \speaker{שלמה.}
איהר\footnoteA[3]{האָן איהר}
נעבעיונגע מער לעססע אייך אַהן {לֵיצים}  דוֹא, דען קענט איהר אייך דערווייל לושטיג מאַכע, ביס מיר געססע האָן. {(}{אַב}{)} {(}{אונטער ווילדעם  געפאָלטער אַללע אַב ביס אויף גומפלכען}{)}


\pend

footnote apparence setting

In order to have right font family in footnoteA, for hebrew text, you must automatically wrap footnote insided hebrew command, using \wrapcontentX reledmac hook. In order to have footnote rule right aligned for series A, you must redefine it.

So

\wrapcontentx[a]{\texthebrew}
\makeatletter
\renewcommand{\footnoterulea}{\right@footnoterule}
\makeatother

General code

% arara: xelatex

\documentclass[10pt,a5paper,twoside]{scrbook}
\usepackage[onehalfspacing]{setspace}

\usepackage[bmargin=2.25cm]{geometry}

\usepackage{scrpage2}
\pagestyle{scrheadings}
\clearscrheadfoot

\ihead{\headmark}
%\automark[chapter]{chapter}
%\automark*[section]{}

\ohead{\pagemark}
\setheadsepline{0.4pt}
\setkomafont{pageheadfoot}{\normalfont\normalcolor\small}\setkomafont{pagenumber}{\normalfont}

%Formatierung der Kopfzeilen:
\addtokomafont{pagehead}{\normalfont}

\setkomafont{disposition}{\normalcolor\bfseries} %Schrift in Überschriften, Inhaltsverzeichnis

\clubpenalty=10000
\widowpenalty=10000

\usepackage[parfill]{parskip}
\usepackage[series={A,B,C}]{reledmac}
\usepackage{reledpar}


%%%\Xendnumberonlyfirstinline

\Xendbeforepagenumber{S.\,}
\Xendafterpagenumber{:\,}
\Xendlineprefixsingle{Z.\,}

\setgoalfraction{0.85}

\lineation{section}
\linenummargin{left}%%right für Zeilennummern rechts
%\setRlineflag{}

\linenumincrement*{5}
\firstlinenum*{0} %Zahl hochsetzen, um Titelei unnummeriert zu haben

\maxchunks{10000}

\usepackage{color}
\usepackage{multicol,multirow, bigdelim}%%times RAUS





\usepackage{amsmath}
\usepackage{fontspec}
\usepackage{polyglossia, xunicode}
\usepackage{libertine}
\setmainfont[Ligatures=TeX]{Linux Libertine}%Linux Libertine O %%EzraSIL hat keine kursiva

\setmainlanguage{german}
\setotherlanguage{hebrew}
\newfontfamily\hebrewfont[Script=Hebrew]{EzraSIL}


\newcommand\einzugjid{\hangindent=5mm\hangafter=1}

\newcommand\speaker[1]{\noindent{#1} \einzugjid
}

\newcommand\einzug{\hangindent=5mm\hangafter=1}

\newcommand\speakerd[1]{\noindent
{\textsc{#1}} \einzug
}

\usepackage[normalem]{ulem}

\wrapcontentX[A]{\texthebrew}
\makeatletter
\renewcommand{\footnoteruleA}{\right@footnoterule}
\makeatother
\begin{document}


\begin{pages}
\begin{hebrew}
 \begin{Leftside}
   \beginnumbering

   \pstart \speaker{שלמה.}
   איהר\footnoteA[3]{האָן איהר}
   נעבעיונגע מער לעססע אייך אַהן {לֵיצים}  דוֹא, דען קענט איהר אייך דערווייל לושטיג מאַכע, ביס מיר געססע האָן. {(}{אַב}{)} {(}{אונטער ווילדעם  געפאָלטער אַללע אַב ביס אויף גומפלכען}{)}

   \pend

   \endnumbering
 \end{Leftside}
\end{hebrew}

\begin{Rightside}

\beginnumbering

\pstart \speakerd{Schlaumeche.} Ihr\footnoteB[3]{hai} \textit{Nebenjungen},wir lassen euch einen  leisen Ton da, dann könnt ihr derweil lustig sein, bis wir gegessen haben. \textit{(Ab.)} \textit{(Unter wildem Gepolter alle ab bis auf Gumpelchen.)} \pend

\endnumbering

\end{Rightside}
\end{pages}
\Pages

\end{document}
  • Thank you so much! But I am afraid that I still have problems in the output. It gives me an empty footnote and a "3]" instead of an uppercase number. Is it just me? Is it my TeX-distribution? – לאה פּאַסטעך Nov 30 '18 at 16:17
  • 1
    As explained in the answer, you must have the newest version of reledmac (2.28.0), that I have just send on CTAN. So wait few day, and upgrade your TeX-distribution – Maïeul Nov 30 '18 at 16:52
  • Any ideas how I can manage this footnotes numbers appear not in superscript? – לאה פּאַסטעך Feb 27 at 9:38
  • please open a new question – Maïeul Feb 27 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.