3

The MWE below, after compiling with pdflatex mwe.tex && bibtex mwe.aux && pdflatex mwe.tex generates a PDF with 3 pages. 1. the sigh frame, 2. the first of two bibliography frames, and finally a contentless "Bibliography II" frame (i.e. empty page/empty frame).

I am aware that allowframebreaks is a terrible idea for actual content and might have is flaws but in this case I'd like to use it nevertheless. What's the reason for the empty frame and how to avoid it (apart from changing the content of the bibliography of course ;)?

\documentclass{beamer}
\usepackage[utf8]{inputenc}
\title{}
\author{}
\date{\today}
\bibliographystyle{IEEEtran}

\usepackage{filecontents}

\begin{filecontents*}{bib.bib}
@article{bornmann2017,
  author="Bornmann, Lutz",
  title="Measuring impact in research evaluations: a thorough discussion of methods for, effects of and problems with impact measurements",
  journal="Higher Education",
  year="2017",
  month=may,
  day="1",
  volume="73",
  number="5",
  pages="775--787",
  issn="1573-174X",
  doi="10.1007/s10734-016-9995-x",
}

@article{meyer2009,
  author = {Meyer, Bertrand and Choppy, Christine and Staunstrup, J{\o}rgen and van Leeuwen, Jan},
  title = {Viewpoint: Research Evaluation for Computer Science},
  journal = {Communications of the ACM},
  volume = {52},
  number = {4},
  month = apr,
  year = {2009},
  issn = {0001-0782},
  pages = {31--34},
  numpages = {4},
  doi = {10.1145/1498765.1498780},
  acmid = {1498780},
  publisher = {ACM},
  address = {New York, NY, USA},
}

@techreport{esposito2018,
  author = {Floriana Esposito and Carlo Ghezzi and Manuel Hermenegildo and Helene Kirchner and Luke Ong},
  title = {Informatics Research Evaluation},
  institution = {Informatics Europe Informatics Europe Informatics Europe Informatics Europe Informatics Europe Informatics Europe Informatics Europe Informatics Europe Informatics Europe Informatics Europe Informatics Europe},
  day = {22},
  month = mar,
  year = {2018},
  url = {http://www.informatics-europe.org/component/phocadownload/},
}
\end{filecontents*}

\begin{document}

\begin{frame}{sigh}
  \cite{*}
\end{frame}

\begin{frame}[c,allowframebreaks]{Bibliography}
  \bibliography{bib}
\end{frame}

\end{document}

I forgot to mention that I tried playing with the factor of allowframebreaks and this can be more or less used as a workaround but since it has to be customized for each case I'd still like to know what triggers it and if a fix is feasible.

I really hope this is not as embarrassing as the previous version of this question (not mine! ;)

9
  • It wasn't my question, it just popped up when I looked for my problem and I found it quite ironic that there was such an easy fix for it while I am for hours wrestling with this (and .bst hacking)... ;)
    – stefanct
    Nov 23, 2018 at 15:48
  • Oh, I'm really sorry! Don't know why I assumed it would be yours! Nov 23, 2018 at 15:48
  • @samcarter I still think your answer was worthwhile to publish even if it didnt perfectly fit my fundamental question. Thanks for your efforts!
    – stefanct
    Nov 23, 2018 at 15:53
  • 1
    They don't get shifted because page breaks within a bibitem are not allowed. This problem would not happen if it would be normal text instead Nov 23, 2018 at 16:38
  • 1
    At the position where the item starts, the frame is not yet full enough, at the next possibility it is too full. That is a complicate situation to solve unless you process the content multiple times Nov 23, 2018 at 16:46

1 Answer 1

4

I think the problem is that you are instructing the framebreak to happen earlier than usual by setting allowframebreaks=0.85. In your case this means that the framebreak is supposed to be somewhere within the 3 bib entry, but bib entries cannot be split across slides.

2 workarounds:

Use the whole frame with allowframebreaks or make the framebreak before the third item, e.g.allowframebreaks=0.75

\documentclass[a4paper]{beamer}
\usepackage[utf8]{inputenc}
\title{}
\author{}
\date{\today}
\bibliographystyle{IEEEtran}

\usepackage{filecontents}

\begin{filecontents*}{bib.bib}
@article{bornmann2017,
  author="Bornmann, Lutz",
  title="Measuring impact in research evaluations: a thorough discussion of methods for, effects of and problems with impact measurements",
  journal="Higher Education",
  year="2017",
  month=may,
  day="1",
  volume="73",
  number="5",
  pages="775--787",
  issn="1573-174X",
  doi="10.1007/s10734-016-9995-x",
}

@article{meyer2009,
  author = {Meyer, Bertrand and Choppy, Christine and Staunstrup, J{\o}rgen and van Leeuwen, Jan},
  title = {Viewpoint: Research Evaluation for Computer Science},
  journal = {Communications of the ACM},
  volume = {52},
  number = {4},
  month = apr,
  year = {2009},
  issn = {0001-0782},
  pages = {31--34},
  numpages = {4},
  doi = {10.1145/1498765.1498780},
  acmid = {1498780},
  publisher = {ACM},
  address = {New York, NY, USA},
}

@techreport{esposito2018,
  author = {Floriana Esposito and Carlo Ghezzi and Manuel Hermenegildo and Helene Kirchner and Luke Ong},
  title = {Informatics Research Evaluation},
  institution = {Informatics Europe Informatics Europe Informatics Europe Informatics Europe Informatics Europe},
  day = {22},
  month = mar,
  year = {2018},
  url = {http://www.informatics-europe.org/component/phocadownload/},
}
\end{filecontents*}

\begin{document}

\begin{frame}{sigh}
  \cite{*}
\end{frame}

\begin{frame}[c,allowframebreaks]{Bibliography}
  \bibliography{bib}
\end{frame}

\begin{frame}[c,allowframebreaks=0.75]{Bibliography}
  \bibliography{bib}
\end{frame}


\end{document}
3
  • I tried playing with the factor of allowframebreaks but that's a hacky workaround...
    – stefanct
    Nov 23, 2018 at 15:41
  • @stefanct I would simply leave out the factor and use the whole sldie Nov 23, 2018 at 15:43
  • Sure, that's not the point though because I am interested in the underlying reason.. Of course one can create the same behavior with the default factor (which is 0.9 IIRC). I have edited the MWE accordingly to show that.
    – stefanct
    Nov 23, 2018 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.