1

This is my first post here, I hope I am doing it right. Sorry for my English, it is not my first language. I have used LaTex for a while but I am ashamed to say that I really do not understand much more than the basic commands. I have recently finished my master's degree and I have to turn in my thesis to our library. They gave me a template (not quite aesthetically pleasing), but I can't complain.

Basically, I am having trouble with the footnote citation format. They use biblatex. They declare \myfootcite in the .sty file like this:

\makeatletter
\DeclareCiteCommand{\myfootcite}
  {}
  {\usebibmacro{citeindex}%
   \usebibmacro{myfootcite}}
  {}
  {}

\newbibmacro*{myfootcite}{%
  \ifciteseen
    {\usebibmacro{myfootcite:note}}
    {\mkbibfootnote{\usebibmacro{footcite:full}%
     \usebibmacro{footcite:save}}}}

\newbibmacro*{myfootcite:note}{\footref{cbx@\csuse{cbx@f@\thefield{entrykey}}}}
\makeatother\makeatletter
\DeclareCiteCommand{\myfootcite}
  {}
  {\usebibmacro{citeindex}%
   \usebibmacro{myfootcite}}
  {}
  {}

\newbibmacro*{myfootcite}{%
  \ifciteseen
    {\usebibmacro{myfootcite:note}}
    {\mkbibfootnote{\usebibmacro{footcite:full}%
     \usebibmacro{footcite:save}}}}

\newbibmacro*{myfootcite:note}{\footref{cbx@\csuse{cbx@f@\thefield{entrykey}}}}
\makeatother

I found an answer here where they explained what to put in the header of the document to list the bibliography like "LAST NAME, First name...", and that's what I need on the footnote. Normally, I wouldn't care but it is the format I have to follow.

Basically, what I want is this: need

And what I am getting is this: get

Also, I was use to write

\begin{thorem}\cite[Theorem 3.4]{ref}
\end{theorem}

in order to cite the theorem but with this new format, I can't do it because it shows names, title, year...(and using \myfootcite does not look good enough), is there any way I can use the same number I get on the footnotes but to make it look bigger?

Again, sorry for my English and thanks for any help!

EDIT:

I'm not sure if I'm doing this minimal example right because I had to go to the .sty file:

\documentclass[letter,oneside,12pt,spanish]{report}
\usepackage[hyperref=true,
            citereset=none,
            url=false,
            isbn=false,
            backref=true,
            style=verbose-note,
            dashed=true,
            maxcitenames=3,
            maxbibnames=3,
            backend=bibtex,
            block=none,
            defernumbers=true]{biblatex}
\addbibresource{\jobname.bib}
\usepackage{filecontents}



\begin{filecontents}{\jobname.bib}
@article{key,
author={{CHASE, Stephen;} and {HARRISON, David} and {ROSENBERG, Alex}},
journal={Mem. Amer. Math. Soc.},
title={Galois theory and Galois cohomology of commutative rings},
year={1965},
volume={52},
pages={1-19},
},
}
\end{filecontents}

\begin{document}

\cite{key}

\printbibliography[heading=bibintoc,title={BIBLIOGRAFÍA},omitnumbers=true]

\end{document}

It works perfectly like this, so I don't know what the problem is with the main template.

  • 2
    You solution of putting names inside braces will cause you other problems and is not the right way to go about it. You want to change the appropriate name format to family-given. However, please update your question to provide a full minimal document example beginning with \document{class} and ending with \end{document} including one bibliography reference. See MWEB. – David Purton Nov 25 '18 at 7:17
  • Edited. Thank you. It works well like that, so I don't know what is the mistake in the template @DavidPurton – ZekeJay Nov 25 '18 at 13:09
  • The linked template does not always follow bes practices, so you should be careful - it might break at any time: The first(!) package it loads is hyperref, but hyperef should usually be loaded last. The .sty enforces ansinew encoding, when UTF-8 is the de fact standard today. Loading biblatex with hyperref=true is no better than the default hyperref=auto. The class sets \parindent to 0, but sets no \parskip. The class loads footmisc twice (with differing lists of options). ... – moewe Nov 25 '18 at 15:52
  • ... Finally the .sty uses something that looks suspiciously like my code from tex.stackexchange.com/q/200286/35864 without attribution. IANAL, but I think technically they are in violation of the CC BY-SA 3.0 license that the code is licensed under (by virtue of having been posted here). Not that I'm particularly fussed about that, but a small link in the source would not have hurt. – moewe Nov 25 '18 at 15:57
2

You can change the name format if you want to display the name in a different order. It is usually a bad idea to force a particular order with curly braces (unless we are talking about corporate authors: Using a 'corporate author' in the "author" field of a bibliographic entry (spelling out the name in full)). I would also avoid wiring the family name in all caps, there are automatic ways to change the format of the family name.

The name order in the bibliography is controlled by sortname, but in fullcite situations biblatex explicitly redefines sortname to use the default settings, this can be avoided by redefining cite:full and footcite:full (remove the \DeclareNameAlias{sortname}{default} in the precode argument to \usedriver).

All in all you probably want something like

\documentclass[spanish]{article}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[url=false,
            isbn=false,
            backref=true,
            style=verbose-note,
            dashed=true,
            maxcitenames=3,
            maxbibnames=3,
            backend=bibtex,
            block=none]{biblatex}
\addbibresource{\jobname.bib}
\usepackage{filecontents}

\renewcommand*{\mkbibnamefamily}[1]{\textsc{#1}}% I can't bring myself to use ALL CAPS
\DeclareNameAlias{sortname}{family-given}

\renewbibmacro*{cite:full}{%
  \usebibmacro{cite:full:citepages}%
  \printtext[bibhypertarget]{%
    \usedriver
      {}
      {\thefield{entrytype}}}%
  \usebibmacro{shorthandintro}}

\renewbibmacro*{footcite:full}{%
  \usebibmacro{cite:full:citepages}%
  \printtext[bibhypertarget]{%
    \usedriver
      {}
      {\thefield{entrytype}}}%
  \usebibmacro{shorthandintro}}

\begin{filecontents}{\jobname.bib}
@article{key,
  author  = {Chase, Stephen and Harrison, David and Rosenberg, Alex},
  journal = {Mem. Amer. Math. Soc.},
  title   = {Galois theory and Galois cohomology of commutative rings},
  year    = {1965},
  volume  = {52},
  pages   = {1-19},
}
\end{filecontents}

\begin{document}
\cite{key}

\printbibliography
\end{document}

Chase, Stephen, Harrison, David y Rosenberg, Alex. <<Galois theory and Galois cohomology of commutative rings>>. En: Mem. Amer. Math. Soc. 52 (1965), págs. 1-19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.