1

As soon as I include \bibliography{Literature} in my code, I get the following error message:

Transcript written on THESISSS.log. This is BibTeX, Version 0.99d (MiKTeX 2.9.6730 64-bit) The top-level auxiliary file: THESISSS.aux The style file: ecca.bst I couldn't open database file LIT.bib ---line 112 of file THESISSS.aux : \bibdata{LIT : } I'm skipping whatever remains of this command I found no database files---while reading file THESISSS.aux

Frankly speaking, I have no idea where to find the THESISSS.aux file (I only know how to delete it).
Any help would be much appreciated!

Best

targa

  • The leading comma in @Book{, is the problem, as moewe says you must have the citation key before that comma so @Book{yermack, then in the tex file you can use \cite{yermack} to reference this work. With no usable key you can not reference it and if you have that error twice you will have two entries with the empty string as key so get the error that you state. – David Carlisle Nov 26 '18 at 10:54
  • you have tagged this biblatex but the error message suggests that you are using bibtex – David Carlisle Nov 26 '18 at 10:55
  • Thank you for your quick feedback! moewe: unfortunately this does not help :/ David Carlisle: interestingly, the code works if I run it as pdfLateX. But it does not work with pdfLateX+MakeIndex+BibTex – targa Nov 26 '18 at 11:10
  • You need a different key for each entry. I can assure you that if you add a key the error message will be different. – moewe Nov 26 '18 at 11:11
  • 1
    The file was indeed in the wrong folder. THANK YOU for your help! It is much appreciated. – targa Nov 26 '18 at 14:46
1

As it turned out in the comments there was a confusion about which .bib file was or should be read by BibTeX (there were several files with similar names in different directories).

This answer is about an earlier version of the question where the .bib file snippet read

  year   = {2018},
  date   = {2018-07-30},
  url    = {https://www.coinmarketcap.com},
}

@Book{,
  author    = {David Yermack},
  title     = {Handbook of Digital Currency},

Each entry in your .bib file must have a unique entry key. This entry key can be used to reference the work in the .tex document with \cite{<entry key>}. The key is given in the .bib entry directly after the opening curly bracket in @<type>{ as in the scheme

@<type>{<entry key>,
  <field_1> = {<value_1>},
  <field_2> = {<value_2>},
  ...
  <field_n> = {<value_n>},
}

So you should have something like @Book{yermack, instead of @Book{,

Technically it is possible to have an empty entry key in a .bib file (with BibTeX, Biber won't like empty keys), but since keys must be unique you can't have two or more entries with an empty key. Additionally citing empty keys might be problematic.

  • I changed the Literature.bib code according to your structure, This results in the same error message. Now there are two of them :/ – targa Nov 26 '18 at 11:17
  • @targa Please update your question wit the new file. Then delete the .aux and .bbl files and recompile again. Upload also the .blg file/the log message. – moewe Nov 26 '18 at 11:20
  • I deleted the .aux files but I do not know how to delete the .bbl files and how to find the .blg file. Do you think this is crucial for the problem solving here? Btw: I ran the code with bibtstyle plain (ecca before) but it did not work :/ (same error message as above) – targa Nov 26 '18 at 11:53
  • @targa It should not be crucial, no. But it would help if we could make sure that nothing interferes. The next best thing is to run your example document in a new clean folder. As you can see at v1.overleaf.com/read/gkhbzzkwjqdg (new Overleaf link) the shown .bib file works with BibTeX's plain style just fine. If you are still getting the Repeated entry errors either your file contains more than you have shown in the question or BibTeX does not pick up the right file. – moewe Nov 26 '18 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.