5

I am using Mendeley to manage my citations. Previously I imported directly to Overleaf using the Mendeley API, however, this doesn't allow the degree of customisation I would like so I have started using the desktop version.

The problem I have is that Mendeley is not generating citation keys for a relatively large number of references. This is not a problem on the online version on Mendeley as the examples below show.

Exported from Mendeley desktop 1.19.2 for Linux

@techreport{,
title = {{Domestic energy v2 PDF WITH NOTES}},
url = {http://www-g.eng.cam.ac.uk/impee/topics/DomesticEnergy/files/Domestic Energy v2 PDF WITH NOTES.pdf},
year = {2005}
}

Exported from Mendeley online

@techreport{2005DomesticNOTES, 
title = {{Domestic energy v2 PDF WITH NOTES}}, 
year = {2005}, 
url = {http://www-g.eng.cam.ac.uk/impee/topics/DomesticEnergy/files/Domestic Energy v2 PDF WITH NOTES.pdf} 
}

This problem appears to have occurred in the last few weeks, as previously I did not notice the issue. I have already had to change all my references from the api citation key style to the desktop citation key style, and do not want to have to keep adding citation keys if they disappear. What is happening and how can I get Mendeley to fill in the missing citations?

  • 3
    If you don't get a good answer here in due time you may want to try contacting the developers directly at mendeley.com/contact-us (I don't have high hopes, but this looks like a bug that should be fixed) – moewe Nov 27 '18 at 10:07
  • (Disclaimer: I'm a support personnel at Overleaf.) The BibTeX exporter in Mendeley Desktop works differently from the Mendeley Web exporter API, though both are developed and maintained by Mendeley. The citation keys are one such difference. Unfortunately we don't have a way to modify this; the Overleaf importer just consumes the content generated by the Mendeley Web exporter... – imnothere Nov 27 '18 at 10:14
  • I agree this is not an issue with Overleaf. I only mention that for context. It is a problem with Mendeley. – Jonno Bourne Nov 27 '18 at 10:19
5

I had the same issue. I solved it in Mendeley Desktop by going to Tools->Options and selecting the Document Details tab. Here you can choose document type, and to have Mendeley Desktop generate a citation key, make sure it is selected for the document types you prefer. It should then generate them the next time you export the .bib file.

| improve this answer | |
  • Thanks for your response! This is interesting, do you have to do it for individual entries or will it generate for all entries that are missing a key? – Jonno Bourne Jan 9 '19 at 14:48
  • It should generate them for all that are that bibliographic type (journal article, book, etc) – BSmicrowaver Jan 11 '19 at 15:46
  • That didn't work for me. I ended up solving the problem by switching to Zotero – Jonno Bourne Feb 25 '19 at 11:02
0

The citation key is only generated if you have Bibtex syncing enabled.

To enable it, go to Tools->Options and the BibTex menu. Tick the checkbox next to "Enable BibTex syncing" and the radio button for "Create one BibTex file for my whole library." Choose a location for the BibTex file, then hit "Ok" or "Apply" and Mendeley will generate Citation Keys for all entries and continue to do so for new entries added to your database.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.