7

I have an overleaf project with a number of EPS files. I use the graphicx package to include them in the final PDF. It compiles properly, and the figures look fine.

I copied the whole project, and didn't touch any of the files. However, it stopped compiling, giving the following error, which appears to relate to one of my figures named pools.eps:

dfTeX error: pdflatex (file /compile/pools-eps-converted-to.pdf): reading image file failed

==> Fatal error occurred, no output PDF file produced!

In the copied project, I tried reuploading the EPS file, but no luck. I also tried deleting the includegraphics command for pools.eps, which did allow all the rest of the code to compile to PDF.

To summarize:

An overleaf project with a number of EPS files compiles perfectly. A copy of the project ceases to compile due to one EPS file in particular, but starts working again when that one figure is removed.

Has anyone encountered this problem before?

4
  • Does the project also fail to compile if the only eps file you include is the one reported in the error? Have you tried the "clear cached files" button (the trash can at the bottom of the list of short error messages)?
    – aoi
    Nov 29, 2018 at 1:27
  • Just tried both of those things, with no luck.
    – Mahkoe
    Nov 29, 2018 at 1:30
  • You may want to contact support@overleaf.com with a link to your project, so that support staff can have a look for you.
    – imnothere
    Nov 29, 2018 at 2:49
  • same problem here. i believe something goes wrong with eps images when copying a project. perhaps they store duplicate files only a single time and messed up the linking somehow. did you figure out a solution?
    – HRSE
    Jan 31, 2019 at 14:43

2 Answers 2

6

I think the problem is happening when TeX Live version is upgraded. You can fix this issue by changing the the TeX Live version in the Menu bar to the date that you created your original project. That worked for me.

1
0

It does also happen with text files, and it most probably has something to do with encodings. When Overleaf copies over the project, some characters will be saved or loaded erroneously. I was quite amazed when I got the message:

! Undefined control sequence.
\UseTextAccent ...up \@firstofone \let \@curr@enc 
                                                  \cf@encoding \@use@text@en...

But when I started looking at it, it happened because the line that was in the error message, contained the word résumé. After removing this, all was fine again. Now I also tried copying the project files manually, copy-pasting this word only etc. No luck. The only logical explanation is that they save, load or execute new files differently than old ones (probably different encoding or pre-processing). This is something the user can not control at all. So yes, you just have to remove such symbols/files until Overleaf fixes the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.