3

I'm trying to get the spacing for footnotes generated by biblatex-chicago to become double-spaced. I've set up double spacing the main part of the text using the following in the preamble:

\usepackage[doublespacing]{setspace}

And to try to get it in the footnotes, I've tried the following

\setlength{\footnotesep}{0.5cm}

as well as

\setlength{\bibitemsep}{24pt}

as well as

\newcommand{\note}[1]{\footnote{\begin{doublespace}#1\end{doublespace}}}

but none of these seems to do the trick for the footnotes.

Any suggestions would be much appreciated!

  • Hi James, I removed the sign off. It's redundant since your user badge is automatically placed in the lower right of the question. – qubyte Feb 29 '12 at 14:13
3

The easiest solution is to change \baselinestretch, though this is usually not recommended; LaTeX provides \linespread, which is probably better to use. But if you want everything double-spaced (or maybe you'll find true double-spacing too much, so 1.5 spacing is another option) try:

\documentclass[12pt]{article}
\usepackage{lipsum}%
\setlength{\footnotesep}{1.5\baselineskip}%
\linespread{1.5}\selectfont%
%\renewcommand{\baselinestretch}{1.66}%
\newcommand{\sometext}{I'm trying to get the spacing for footnotes
  generated by biblatex-chicago to become double-spaced. I've set up
  double spacing the main part of the text using the following in the
  preamble:} %

\begin{document}

\sometext%
\footnote{\sometext}%

\sometext%
\footnote{\sometext}%

\end{document}

\footnotesep is for the space between footnotes; \baselinestretch for the (normal) vertical distance between lines. Note that you need \selectfont after \linespread for any changes to take effect (which means you can make changes at specific points in your document). Also, \bibitemsep is for the space between items in your bibliography.

2

First of all, that's a bad design. setspace is designed to avoid the problem of setting \baselinestretch to the whole document, so that one can maintain footnotes and block quotes in single spacing.

You can use footmisc package and change \footnotelayout

\documentclass[12pt]{article}
    \begin{filecontents}{\jobname.bib}
        @book{test1,
            author = {John Doe},
            title = {Example book to be cited},
            address = {Nowhere},
            publisher = {Some Publisher},
            year = {1990},
            }
    \end{filecontents}
\usepackage{biblatex-chicago}
  \addbibresource{\jobname.bib}
\usepackage{setspace}
\usepackage{footmisc}
\renewcommand{\footnotelayout}{\doublespacing}
\newcommand\lipsum{Lorem ipsum dolor sit amet, consectetur adipiscing elit. 
    Praesent egestas lectus eu nisi placerat sodales. Praesent a vestibulum tortor. 
    Aliquam sem lectus, dapibus in aliquam sit amet, euismod sed orci.  
    Phasellus posuere placerat mi ut accumsan. Proin eu interdum nunc.  
    Class aptent taciti sociosqu ad litora torquent per conubia nostra,  
    per inceptos himenaeos. Aenean semper elementum nulla, ac mattis erat  
    commodo ac. Etiam mi tellus, lobortis vitae ultrices quis, tempus at ipsum.  
    Donec diam leo, egestas at vestibulum eget, vestibulum eu est. Cras purus 
    augue, aliquet eget gravida id, aliquet quis lacus. Nullam accumsan,  
    metus sed placerat tincidunt, lacus leo pulvinar ipsum, vitae suscipit  
    mi mi auctor odio. Donec tristique, nisi ut rhoncus molestie, est  
    justo ultricies nulla, et consequat nunc est quis sem.}
\begin{document}
\singlespacing
\lipsum

\lipsum\autocite[\lipsum][100]{test1}

\lipsum
\end{document}
  • If I understand what you mean by 'change the spacing environment within the footnote text', you need to change \footnotesep. (Also, I think your .bib entry is missing a closing brace.) – jon Mar 1 '12 at 1:45
  • @jon I agree with you about \footnotesep. I just think it's a further development of the issue (e.g.\footins should`also be changed). I also can't tell how much those lengths should be changed. I hope you don't think I meant your answer to be bad design, since I was talking about doublespaced footnotes. Meanwhile I found a simpler solution and updated my answer. – henrique Mar 1 '12 at 2:32
  • footmisc's \footnotelayout hook does seem like a better solution insofar as it is less likely to be an ad hoc solution. You're right though: I assumed that the request for doublespaced footnotes along with the call to the setspace package meant the OP was looking for double-spacing everywhere; but a footnote-only solution, as rare as such a need might be, is good to have as well. +1 – jon Mar 1 '12 at 3:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.