1

How can I disable the automatic transliteration of Arabic? I want to write my French report including some Arabic sentences. So I am using the arabtex package but when writing an Arabic sentence like this

\begin{arabtext}
السَلامُ عَليكم ورَحمةُ الله وبَركاته  
\end{arabtext}

I got this:

السَلامُ عَليكم ورَحمةُ الله وبَركاته 
ālsalāmu alykm wrah.mtu āllh wbarkāth

I don't want this transliteration. How can I disable it?

  • Welcome to TeX.SE! Can you please add a short compilable code showing your issue? – Kurt Nov 30 '18 at 18:42
  • @Kurt I know the policy on MWEs, but in this case the answer is right there in the Arabtex documentation, in a section about this single topic that is listed in the table of contents - so it's not even buried in a hard-to-find place! There's no need to see an example to answer the OP's question. – alephzero Nov 30 '18 at 20:20
5

The command you want is \transfalse. For example,

\documentclass[12pt]{article}
\usepackage{arabtex}
\begin{document}
\setarab
\novocalize
\spreadtrue
\transfalse
\begin{RLtext}
klAm fI m.h.d al-_hyr
\end{RLtext}
\end{document}

output

2

If you're not limited to (la)tex, why don't you use arabxetex package?

I think using it with xelatex have more options than arabtex, e.g. you can change the main font for Arabic typesetting (default is Amiri font).

\documentclass{article}
\usepackage{arabxetex}
\begin{document}

\begin{arab}[voc]
السَلامُ عَليكم ورَحمةُ الله وبَركاته  
\end{arab}

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.