1

When I start tikzedt on windows 10enter image description here

I face the problem of a path variable as in fig. A solution is requested.

  • 1
    The error message seems quite clear: you need to install latex. If it is installed then you need to set the paths correctly but we cannot advise on this if you don't tell us what latex distribution you are using - and where/how it was installed. – Andrew Dec 5 '18 at 23:39
  • I have installed miktex 2.9 distribution with texstudio. It is working fine i.e. I can write reports etc. using these. How to specify the path in this case? – aslam Dec 6 '18 at 4:23
  • there are several ways to check and adjust path, but in order to help we would need to see your default. so in the task bar where you can search type cmd and select command prompt. In the console type where /r c: pdfLaTeX then enter key use mouse to highlight the response and then the enter key to store in clipboard. Paste the result in your question using the edit at lower left. Also at the command prompt type path again highlight all of the response and hit enter key then paste that in question – user170109 Dec 6 '18 at 14:02
1

It took me three days searching for the answer to finale understand the problem and how to correct it by myself. The solution for Windows I share below.

In Settings -> Settings: Set the "Path to PdfLatex" as:

C:/Users/YOURNAME/AppData/Local/Programs/MiKTeX 2.9/miktex/bin/x64/pdflatex

It should be without the extension ".exe" at the end and without quotes. It should be a very similar path to the result path when you click at:

Settings -> Try to install missing Latex packages -> I use Miktex

if your installation is correct. You MUST regenerate the headers by clicking on:

Compilation -> (Re-)Generate precompiled headers

Then TikZEdt should work fine once again.

After redefining past, you must regenerate the headers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.