1

How to restrict the number of authors to be viewed in document? Or is it all right to write it in this way?

@article{Pablo2016,
  author={H. Pablo and G. N. Whittaker and A. Popowicz and S. M. Mochnacki and R. Kuschnig and C. C. Grant and A. F. J. Moffat and S. M.
Rucinski and J. M. Matthews and A. Schwarzenberg-Czerny and G. Handler and W. W. Weiss and D. Baade and G. A. Wade and E.
Zocłońska and T. Ramiaramanantsoa and M. Unterberger and K. Zwintz and A. Pigulski and J. Rowe and O. Koudelka and P.
Orleański and A. Pamyatnykh and C. Neiner and R. Wawrzaszek and G. Marciniszyn and P. Romano and G. Woźniak and T.

enter image description here

\bibliographystyle{czplainnat}    

\renewcommand{\bibname}{Seznam použité literatury}

\bibliography{literatura}

I cite

\citet{}

or

\citep{}
5
  • 7
    use maxnames or maxbibnames, see the biblatex documentation. – Ulrike Fischer Dec 9 '18 at 15:35
  • 2
    Whether or not the full author list is required or not depends on the particular journal/scientific society style, and is not really a TeX question. Some styles (e.g. APA) require \dots between the 7th and last authors. Ulrike's comment shows you how to control the numbers in the more simple cases if needed. Some – Alan Munn Dec 9 '18 at 17:39
  • Note that Ulrike's suggestion only works if you are really using biblatex (as your tagging suggests). If you are not using biblatex a different method may be needed. Please show us not only your .bib entry but also a short example document that demonstrates which bibliography and citation packages you load (e.g. cite, natbib, jurabib, biblatex, ...), which style you use (the argument of \bibliographystyle for BibTeX-based solution or the value of the style option for biblatex) and how you create your bibliography. – moewe Dec 9 '18 at 18:18
  • 1
    Thank you for the edit. The code you have shown us so far is not a MWE (tex.meta.stackexchange.com/q/228) or MWEB (tex.meta.stackexchange.com/q/4407), which is what I gad in mind when I asked for an example document. Please consider adding useful code examples to your questions in the future. You have already quite some experience on this site and in almost all of your question an MWE was either integral in helping your or made things much easier. It gets a bit frustrating (and is ineffective) if we have to ask for more information every time before we can start helping you. – moewe Dec 9 '18 at 19:03
  • Anyway, the code shown so far shows that the question was tagged incorrectly (so I retagged it). That means that Ulrike's advice won't work for you. czplainnat has no built-in option to restrict the number of displayed names as easily as biblatex. – moewe Dec 9 '18 at 19:05
1

A solution with biblatex and the program biber

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
    @article{Pablo2016,
    author={H. Pablo and G. N. Whittaker and A. Popowicz and S. M. Mochnacki and R. Kuschnig 
        and C. 
            C. Grant and A. F. J. Moffat and S. M.
            Rucinski and J. M. Matthews and A. Schwarzenberg-Czerny and G. Handler and W. W. Weiss 
            and 
            D. Baade and G. A. Wade and E.
            Zocłońska and T. Ramiaramanantsoa and M. Unterberger and K. Zwintz and A. Pigulski and 
            J. 
            Rowe and O. Koudelka and P.
            Orleański and A. Pamyatnykh and C. Neiner and R. Wawrzaszek and G. Marciniszyn and P. 
            Romano and G. Woźniak and T.},
        title ={An article with a lot of authors},
        date ={2018-12-20},
        journal= {The journal for Articles},
        location ={New York and Bangkok},
    }
\end{filecontents*}

\documentclass{article}
\usepackage[czech]{babel}
\usepackage{csquotes}
\usepackage[style=authoryear,maxbibnames=99]{biblatex}
\addbibresource{\jobname.bib}
\begin{document}

foo~\parencite{Pablo2016} or bar~\textcite{Pablo2016}

\printbibliography[title=Seznam použité literatury]

\makeatletter  % only for demonstration
\def\blx@maxbibnames{1}
\blx@resetdata
\makeatother

\printbibliography[title=Seznam použité literatury]

\end{document}

enter image description here

Using biblatex instead of BibTeX and bibliographysytle. is not really difficult: Replace your

\bibliographystyle{czplainnat}    
\renewcommand{\bibname}{Seznam použité literatury}
\bibliography{literatura}

with the following which should go into the preamble(!):

\usepackage[style=authoryear,maxbibnames=1]{biblatex}
\addbibresource{<your bibfile>.bib}

in the text use \textcite, \parencite, or simply\cite` and at the end

\printbibliography[title=Seznam použité literatury]
15
  • 1
    see edited answer at the end, where I wrote what you should do. I suppose that you already have natbib or something else loaded. – user2478 Dec 21 '18 at 6:47
  • 1
    natbib is no more needed for biblatex – user2478 Dec 21 '18 at 7:41
  • 1
    that it is an old bbl-file, created by bibtex and not biber. Delete it and run the document again. – user2478 Dec 23 '18 at 9:35
  • 1
    in the folder of your document. Some Editors have an option like "Clear all help files". Then it is done by the editor. – user2478 Dec 23 '18 at 9:47
  • 1
    Your document has the filename prace.tex and you know the directory in which you saved this document. And in this directory are all the other help files, like prace.log, prace.aux... , and brace.bbl. This one you should delete. – user2478 Dec 23 '18 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.