0

I need to put German quotation marks (,,text") around all titles in biblatex except with titles from books.

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{darwin,
    Author = {Charles Darwin},
    Publisher = {Cambridge University Press},
    Title = {The Correspondence of Charles Darwin, 1821-1836},
    Year = {1985}}

@Electronic{wade,
  title     = {Darwin, Ahead of His Time, Is Still Influential},
  author    = {Nicholas Wade},
  date       = {2009-02-09}
  url       = {https://www.nytimes.com/2009/02/10/science/10evolution.html?ref=sciencespecial2},
  urldate   = {2018-10-08}
  }


\end{filecontents*}


\documentclass{article}

\usepackage[style=verbose]{biblatex}
\addbibresource{\jobname.bib}

\begin{document}
Bla Bla Bla Bla Bla Bla \autocite{darwin} \autocite{wade}

\printbibliography
\end{document}

I only found questions about quotation marks within the title. However, I need quotation marks outside the title. How can I do that?

enter image description here

3
  • Traditionally works that stand on their own (books, journal names, ...) are printed in italics, while works that are part of a larger 'container' (chapters in books: @inbook, @incollection, @articles, ...) have their titles in quotation marks. Do you explicitly want all titles in quotation marks?
    – moewe
    Dec 11, 2018 at 9:17
  • 1
    Now that I edited the question I'm a bit confused: Do you want the quotation marks to end before the "1821-1836"? Would that not mean you actually want quotation marks within the title (since the entire title as given in the .bib file is "The Correspondence of Charles Darwin, 1821-1836") and not outside it?
    – moewe
    Dec 11, 2018 at 9:31
  • Thanks for your answer. I'm sorry I drew the quotation marks wrongly. And thanks to your first comment I also noticed that I need all bibliography genres in quotation marks except for titles from books. I'm sorry that I didn't notice that earlier. I added that to the question.
    – heidil
    Dec 11, 2018 at 16:47

1 Answer 1

1

As I explained in the comments, there is some method in the way biblatex formats the titles for certain entry types: The titles of works that stand on their own (@books, @collections, entire journals, ...; basically anything you can read on the spine or the cover of a book when you stroll through a library) are in italics, while dependent works that constitute only a part of a whole (@inbook, @incollection, @article, ...; these are mainly titles you can only find out about when you open a book or volume and consult the table of contents) have their titles formatted with quotation marks.

You can find an explanation of the default settings in Remove Quotation Marks from Style. You probably like to try

\DeclareFieldFormat[online]{title}{\mkbibquote{#1\isdot}}

if you really want only book titles in italics and the rest in quotation marks, you could try

\DeclareFieldFormat*{title}{\mkbibquote{#1\isdot}}
\DeclareFieldFormat[book]{title}{\mkbibemph{#1\isdot}}

For German-style quotation marks it should be enough to load babel and pass ngerman as loading option and then load csquotes for language-dependent quotation marks. Of course that is assuming that the rest of your document is in German, but I think that is a fair assumption if you are looking for German quotation marks.

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{darwin,
  author    = {Charles Darwin},
  publisher = {Cambridge University Press},
  title     = {The Correspondence of Charles Darwin, 1821--1836},
  year      = {1985},
}
@electronic{wade,
  title   = {Darwin, Ahead of His Time, Is Still Influential},
  author  = {Nicholas Wade},
  date    = {2009-02-09},
  url     = {https://www.nytimes.com/2009/02/10/science/10evolution.html},
  urldate = {2018-10-08},
}
\end{filecontents*}

\documentclass[ngerman]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[style=verbose]{biblatex}

\DeclareFieldFormat[online]{title}{\mkbibquote{#1\isdot}}

\addbibresource{\jobname.bib}

\begin{document}
Lorem \autocite{darwin} ipsum \autocite{wade}

\printbibliography
\end{document}

Darwin, Charles. The Correspondence of Charles Darwin, 1821–1836. Cambridge University Press, 1985.//Wade, Nicholas. „Darwin, Ahead of His Time, Is Still Influential“. 9. Feb. 2009. url: https://www.nytimes.com/2009/02/10/science/10evolution.html (besucht am 08.10.2018).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .