5

Given the following minimal example:

\RequirePackage{filecontents}

\begin{filecontents*}{\jobname.xmpdata}
\Title{Minimal Example}
\Author{John Doe}
\end{filecontents*}

\documentclass{article}
\usepackage[a-1b]{pdfx}

\begin{document}
    Test
\end{document}

and

$pdf_mode = 5;
$xelatex = "xelatex --shell-escape %O %S";
$xdvipdfmx = "xdvipdfmx -z 0 -o %D %O %S";
$dvi_mode = 0;
$postscript_mode = 0;

in the latexmkrc does not converge when built with latexmk. I have also tried

$pdf_mode = 1;
$pdflatex = "xelatex --shell-escape --output-driver=\"xdvipdfmx -z 0\" %O %S";

in the latexmkrc with the same result.

The --shell-escape and -z 0 are added as required by pdfx. The output file itself appears to be produced correctly.

1 Answer 1

3

By running latexmk -diagnostics, I was able to find out that, apparently, the pdfx package causes the creation of a file creationdate.timestamp which latexmk recognizes as an input file. And it changes on every run.

By adding $hash_calc_ignore_pattern{'timestamp'} = '^'; to the latexmkrc file, you can tell latexmk to ignore all lines of .timestamp files, thereby working around the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .