I am trying to obtain a non-standard citation style that includes only the last name of the first author, and the year it was published. As an example at the moment I have this:



author = {Styleiz Stupid and Don Knowhy},
title = {Using totally random citation styles to write a thesis},
year = {1999},
volume = {11},
pages = {232-254},
journal = {Journal of Stupid Citation Styles}


On the tex file I cite with

A stupid random citation style was also used by \cite{Stupid1999}

The output is then:

A stupid random citation style was also used by [Stupid and Knowhy, 1999]

And what I want it to be:

A stupid random citation style was also used by [Stupid,1999]

Similar outputs to this without comma would also be appreciated, I just need that it does not include any second author or et al. in the in-line citation.

Additionally, on the references part I also need the output to be like

    [Stupid,1999] Stupid, S., Knowhy, D., Using totally random citation 
                  styles to write a thesis. Journal of Stupid Citation 
                  Styles, 1999, vol. 11, p. 232-254

The important part about this output is that it needs to be in this indentation style. The order of the citation can also be (authors, year, title, rest). At the moment I'm using \bibliographystyle{apalike} cause it was the only similar option, however this will not be suitable to conclude my work.

Looking forward in advance to your suggestions.

Kind regards

Example code with package list:


\usepackage{verbatim}  % Needed for the "comment" environment to make LaTeX comments
\usepackage{vector}  % Allows "\bvec{}" and "\buvec{}" for "blackboard" style bold vectors in maths
\usepackage[font=small, labelfont=bf, justification=centering, format=hang]{caption}
,backend=bibtex      % biber or bibtex
,style=authoryear    % Alphabeticalsch
,style=numeric-comp  % numerical-compressed
,sorting=nyt        % no sorting
,sortcites=true      % some other example options ...
,doi=true            % prints doi
,natbib=true         % if you need natbib functions


    A stupid random citation style was also used by \cite{Stupid1999}



biblatex.sty error line 3350 Command \Rn already defined \endgroup} and multiple warnings
  • Welcome to TeX SX! Do you use biblatex?
    – Bernard
    Dec 11, 2018 at 12:52
  • @Bernard I'm using bibtex at the moment, I've tried implementing biblatex, however I was not even able to print the bibliography. Dec 11, 2018 at 12:55
  • 1
    If I comment out all the package I don't have and substitute the .bib files I also don't have, your code compiles reasonable fine. Dec 11, 2018 at 13:28
  • 1
    Off-topic: \usepackage{hyperref} should be one of the last packages you load. Dec 11, 2018 at 13:28
  • 1
    Also don't load the same packages multiple times Dec 11, 2018 at 13:29

1 Answer 1


This answer has been completely reworked for biblatex 3.13 and biblatex-ext.

See the edit history for the version abusing the alphabetic style.

Thanks to https://github.com/plk/biblatex/issues/861 it is possible to properly suppress the "et al." even in authoryear styles (see Remove "et al." only from citation and maintain it in bibliography). This means we can use the authoryear style ext-authoryear as basis and employ introcite for the labels in the bibliography.


  mincitenames=1, maxcitenames=1,
  nohashothers=true, nosortothers=true,
  introcite=label, dashed=false]{biblatex}






  • @samcarter I tried to apply both suggestions, however the bibliography is not printed due to a displayed error: The top-level auxiliary file: maint.aux I found no \citation commands---while reading file maint.aux I found no \bibdata command---while reading file maint.aux I found no \bibstyle command---while reading file maint.aux (There were 3 error messages) Dec 11, 2018 at 14:13
  • @JoséCardoso You must run Biber instead of BibTeX, see tex.stackexchange.com/q/154751/35864 (and tex.stackexchange.com/q/63852/35864 for background).
    – moewe
    Dec 11, 2018 at 14:14
  • That's exactly it. I forgot to switch to biber. It's working now! Thank you so much!!!!!!!! I'm going to input this into my main files. Dec 11, 2018 at 14:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .