0

I've just installed MiKTeX and TeXMaker on my PC (previously worked on Overleaf which is fine until you have to write a whole master thesis).

I have trouble while trying to compile a document, cf. screenshot below enter image description here

After some preliminary research, it seems that it might be related to my MiKTeX installation and more precisely the paths. Indeed, MiKTeX signals an issue (cf. 2nd screenshot below) enter image description here

This is where I'm a bit lost. I've seen different solutions on different forums; 1) By modifying the MiKTeX Console -> Settings -> Directories but I don't know exactly how 2) By modifying the PATH environment variable on my PC but again I don't know exactly how. Plus, it seems that the correct path is already there (cf. screenshot below, apologies for the interface language in french). enter image description here

There is obviously something that I don't understand. Does anyone have an answer/ an idea to solve the problem ? Would be great !

Thanks in advance. Rodolphe

PS. Working on Windows 10, MiKTeX 2.9, Texmaker 5.2. I've only tried Quick Build.

  • Welcome to TeX SX! Do you have any reason not to install MiKTeX for every user of the computer? – Bernard Dec 13 '18 at 19:44
  • Not immediately familiar with Texmaker, but in TeXworks provided by MiKTeX, you need to use %1.tex to refer to the first argument, not %.tex. So, the pdflatex call should look like pdflatex -syntex=1 -interaction=nonstopmode %1.tex. It seems this is likely a TeXmaker setting that needs updating? – whatisit Dec 13 '18 at 19:45
  • Hi. No, I'm the only user of the computer. How can I change the installation / How can it be useful ? Thanks for your swift answer! – Rodolphe Vanderveken Dec 13 '18 at 19:48
  • Hi @whatisit. I've tried your solution. It doesn't seem to solve the situation, unfortunately,as the error message is now "pdflatex -synctex=1 -interaction=nonstopmode %1.tex" – Rodolphe Vanderveken Dec 13 '18 at 19:53
  • If you install MiKTeX for every user (even if you're the only user really), it will be in C:\ Program Files, which is part of the path. Desure to reinstall TeXmaker after you've reinstalled MiKTeX. Personally, I have no problem with this installation (under Windows 7 Pro). – Bernard Dec 13 '18 at 20:17
0

For anyone interested and who might have a similar problem, the solution is the following;

"If you install MiKTeX for every user (even if you're the only user really), it will be in C:\ Program Files, which is part of the path. Desure to reinstall TeXmaker after you've reinstalled MiKTeX"

Thanks @Bernard !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.