3

The below MWE gives errors. Moving the line \usepackage{pdfx} below the biblatex package (right before \begin{document}) will currently not give explicit errors, but “it is best if pdfx is the first package loaded” (pdfx manual p. 16).

What would be some ways to handle this?

\documentclass{article}

\usepackage{pdfx}

\usepackage{biblatex}
\addbibresource{biblatex-examples.bib}

\begin{document}

test
\parencite{knuth:ct}
\printbibliography[heading=none]

\end{document}

closed as off-topic by TeXnician, Sebastiano, svenper, Stefan Pinnow, Mensch Dec 25 '18 at 12:07

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    See also github.com/plk/biblatex/issues/846. I have no idea what pdfx is doing that things fail so spectacularly. Plus I'm not sure if it really is good advice to load pdfx as early as possible given that it loads hyperref... Any hint would be greatly appreciated. – moewe Dec 15 '18 at 15:08
  • 3
    Ulrike Fischer found the problematic line in pdfx (see her comment in the linked issue). For now the workaround that stays closest to the requirements to load pdfx as early as possible is to only load the ifthen package before pdfx. – moewe Dec 15 '18 at 16:57
  • 4
    I'm voting to close this question as it can be solved by updating pdfx to version 1.6.1 (2018/12/22). – TeXnician Dec 25 '18 at 10:43

Browse other questions tagged or ask your own question.