3

I am trying to use Batang font for Koreanisch and it doesn't work. If I try a simple font, for example, Calibri it works and the file compiles. But if I use a font like Meiryo,PMingLiU,Batang and just fails. I am running this from the command line and I allow to install packages on the fly:

xelatex.exe -enable-installer test.tex

What should I do in order to add this font, if automatically doesn't work?

Thank you, Adrian

1

2 Answers 2

1

Sam Carter has given a very good link on how to use Unicode fonts at

https://yoo2080.wordpress.com/2014/03/09/how-to-use-unicode-in-latex-by-luatex-or-xetex/

However this was written prior to the font changes in Windows 10 when many were removed from some locales. So in order for windows 10 users to load those fonts you either need to change the default locale or use the better options as found further down in this link

https://docs.microsoft.com/en-us/windows/deployment/windows-10-missing-fonts

or add a relevant language pack as described here

https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/add-language-packs-to-windows

these can be loaded on demand (like MiKTeX packages) as described here

https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/features-on-demand-language-fod

2
  • Thanks. I have solved the problem. I just installed the language package from windows and now works.
    – Adrian
    Commented Dec 17, 2018 at 17:05
  • OK I will add that link too
    – user170109
    Commented Dec 17, 2018 at 17:08
0

A faster workaround for this problem is to install the language package from windows. For example, installing the Korean language will bring Batang font and everything will be ok. Now I can generate pdf with Batang font.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .