2

I do have the following problem: I wrote my theorem, and in the end I wanted to change it to \documentclass[12pt,a4paper,twoside]{report} instead of \documentclass[12pt,a4paper]{report}. But when I made these change the format of my document is changed, in some phage a random unexpectedly big space area are added, and the itemze spacer are increased but only in a few page, the other pages stay the decent look.

Can anybody help me what could I make wrong ?

  • I assume that twoside also changes the geometry settings of your pages. Try using the geometry package in order to set the page layout to your needs... – Raven Dec 17 '18 at 18:06
  • 1
    twoside defaults to \flushbottom so you may prefer \raggedbottom (as used for oneside) – David Carlisle Dec 17 '18 at 19:05
1

Running the following document with oneside shows in the logfile (at the end) the following setting:

\textwidth=418.25368pt
\textheight=591.5302pt

These values can be used for twoside to get the same layout, except that oneside uses \raggedbottom:

\documentclass[12pt,a4paper,twoside]{report}
\usepackage{geometry}
\geometry{textwidth=418.25368pt,textheight=591.5302pt}
\usepackage{blindtext}
\begin{document}
    \blinddocument
\end{document}
  • Thanks for your answer, and how can I chech that oneside is using \raggedbottom ? – Péter Kerekes Dec 17 '18 at 21:01
  • That is the default setting for report. And can be seen in the output. – user2478 Dec 18 '18 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.