4

There have been a few updates to pstricks on ctan recently. The code:

\documentclass{article}
\usepackage{pstricks}
\begin{document}

   \begin{pspicture}(0,5)(2,2)
     \rput(1,1){Hi!}
   \end{pspicture}

   \begin{pspicture}(0,5)(2,2)
      \psline[linewidth=2pt]{->}(1.5,0)(0,0)
   \end{pspicture}

\end{document}

compiles fine with latex but when you run it through make4ht, which is a nice front-end to tex4ht, it crashes withe the first pspicture environment giving the error

! Extra }, or forgotten \endgroup. \endpspicture ->\pst@killglue \endgroup \egroup \ifdim \wd \pst@hbox =\z@ \e...

and the second environment giving

! Undefined control sequence. \endpspicture ...-\pst@dimb \pst@dimd =\pst@tempa \pst@dimd \advance \pst@di...

As the code is so simple, and it worked previously, I don't think it's anything that I am doing but would be very happy to be corrected.

Does anyone see a work around for this?

4

The first one is fixed with the update from today and the second one seems to be a problem with t4ht. In pstricks.4ht the line 80 should be

\ifx\pst@tempa\@undefined\else

instead of current

\ifx\pst@tempa\@empty\else

However, this problem seems to be a long standing one. So I am wondering that it shouzld have worked in the past ...

  • 2
    thanks, I've updated the tex4ht sources – michal.h21 Dec 18 '18 at 11:20
  • Thanks very much for the quick reply! I had already downloaded the pstricks updates before I posted and, at least for me, the updates do not fix the first issue BUT modifying pstricks.4ht as you suggest fixes both problems for me! The reason that I think this worked before the latest round of updates is that I have a lot of (more complicated) test files that worked before I updated pstricks earlier this week (and then again today), and these test files worked previously... In fact, with your fix in place, all of my "more complicated" tests past again. Thank you! – Andrew Dec 18 '18 at 13:34
  • @michal.h21 Any idea when the next tex4ht release, that incorporates this fix, is likely to appear on ctan? – Andrew Dec 18 '18 at 13:35
  • @Andrew it usually takes few days, maybe even tomorrow – michal.h21 Dec 18 '18 at 13:41
  • @michal.h21 You're too efficient :) – Andrew Dec 18 '18 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.