0

I do use MikTeX (with MikTeX Console 2.9.6888) and today I tried to update my packages. I experienced some errors during the update but single package update was installed after a restart and another update run.

However, after the update, pdflatex does not seem to work anymore. I use the MWE in mwe.tex

\documentclass{article}
\begin{document}
Hello World!
\end{document}

to test pdflatex on the console with

pdflatex -halt-on-error mwe.tex

The only output I get is:

This is pdfTeX, Version 3.14159265-2.6-1.40.19 (MiKTeX 2.9.6880 64-bit)

Afterwards, nothing happens. I can escape the shell but no output is created at all as also mentioned here.

I do have admin privileges on my system and already tried to delete the FNDB's for the user and admin in as proposed here

C:\ProgramData\MiKTeX\2.9\miktex\data\le
C:\Users\[USER]\AppData\Local\MiKTeX\2.9\miktex\data\le

and rebuild both using the MikTeX console as well as initexmf:

initexmf --update-fndb
initexmf --mklinks

for the user as well as for the admin with --admin. However, nothing happens.

I noticed that when I execute pdflatex on the command line, 2 pdflatex tasks are created and visible in the task manager:

enter image description here

Is it possible that user and admin both execute an instance of pdflatex and lock each other? How can I get rid of the problem?

In case I terminate the execution of pdflatex with the PID of the run using less memory, the other keeps on running and locks the admin fndb from the path above, so I guess the remaining process is the admin run. If I kill the pdflatex process using more memory, both processes are terminated.


pdflatex.log

FYI the output from pdflatex.log

2018-12-19 17:12:00,793+0100 INFO  pdflatex - starting with command line: pdflatex -halt-on-error mwe.tex
2018-12-19 17:12:00,793+0100 INFO  pdflatex - allowing known shell commands
2018-12-19 17:12:00,793+0100 INFO  pdflatex - enabling input (output) from (to) processes
2018-12-19 17:12:00,823+0100 INFO  pdflatex - going to create file: pdflatex.fmt
2018-12-19 17:12:07,863+0100 ERROR pdflatex - D:\Programme\MiKTeX\2.9\miktex\bin\x64\initexmf.exe did not succeed; exitCode: 1
2018-12-19 17:12:07,863+0100 ERROR pdflatex - output:
2018-12-19 17:12:07,863+0100 ERROR pdflatex - 
Sorry, but "MiKTeX Configuration Utility" did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

C:\Users\[USER]\AppData\Local\MiKTeX\2.9\miktex\log\initexmf.log

2018-12-19 17:12:07,863+0100 FATAL pdflatex - The memory dump file could not be found.
2018-12-19 17:12:07,863+0100 FATAL pdflatex - Info: fileName="pdflatex.fmt"
2018-12-19 17:12:07,863+0100 FATAL pdflatex - Source: Libraries\MiKTeX\TeXAndFriends\texmfapp.cpp
2018-12-19 17:12:07,863+0100 FATAL pdflatex - Line: 689
2018-12-19 17:12:07,873+0100 INFO  pdflatex - finishing with exit code 1

initexmf.log

2018-12-19 17:12:01,043+0100 INFO  initexmf - starting: MiKTeX Configuration Utility 2.9.6888 (MiKTeX 2.9.6880 64-bit)
2018-12-19 17:12:01,043+0100 INFO  initexmf - Operating on the private (per-user) MiKTeX setup
2018-12-19 17:12:01,043+0100 INFO  initexmf - starting with command line: initexmf --dump-by-name=pdflatex --engine=pdftex
2018-12-19 17:12:01,053+0100 INFO  initexmf - running: miktex-makefmt.exe --engine=pdftex --dest-name=pdflatex --no-dump pdflatex.ini --engine-option=-tcx=cp227.tcx
2018-12-19 17:12:07,853+0100 ERROR initexmf - sub-process error output has been saved to 'C:\Users\[USER]\AppData\Local\MiKTeX\2.9\miktex\log\miktex-makefmt_2018-12-19-171207.out'
2018-12-19 17:12:07,853+0100 FATAL initexmf - The executed process did not succeed.
2018-12-19 17:12:07,853+0100 FATAL initexmf - Info: fileName="D:\Programme\MiKTeX\2.9\miktex\bin\x64\miktex-makefmt.exe", exitCode="1"
2018-12-19 17:12:07,853+0100 FATAL initexmf - Source: 
2018-12-19 17:12:07,853+0100 FATAL initexmf - Line: 0

miktex-makefmt_2018-12-19-171207.out

Running miktex-pdftex.exe...
This is pdfTeX, Version 3.14159265-2.6-1.40.19 (MiKTeX 2.9.6880 64-bit) (INITEX)
entering extended mode
(D:/Programme/MiKTeX/2.9/tex/latex/00miktex/pdflatex.ini
(C:\Users\raed_ma\AppData\Roaming\MiKTeX\2.9\tex\generic\config\pdftexconfig.te
x)
(D:\Programme\MiKTeX\2.9\tex/latex\base\latex.ltx
(D:\Programme\MiKTeX\2.9\tex/latex\base\texsys.cfg)
./texsys.aux found

\@currdir set to: ./.

Assuming \openin and \input 
have the same search path.

Defining UNIX/DOS style filename parser.

catcodes, registers, parameters,

LaTeX2e <2018-12-01>

hacks, control, par, spacing, files, font encodings, lengths,

====================================

Local config file fonttext.cfg used

====================================

(D:\Programme\MiKTeX\2.9\tex/latex\base\fonttext.cfg
(D:\Programme\MiKTeX\2.9\tex/latex\base\fonttext.ltx

=== Don't modify this file, use a .cfg file instead ===

(D:\Programme\MiKTeX\2.9\tex/latex\base\omlenc.def)
(D:\Programme\MiKTeX\2.9\tex/latex\base\t1enc.def)
(D:\Programme\MiKTeX\2.9\tex/latex\base\ot1enc.def)
(D:\Programme\MiKTeX\2.9\tex/latex\base\omsenc.def)
(D:\Programme\MiKTeX\2.9\tex/latex\base\t1cmr.fd)
(D:\Programme\MiKTeX\2.9\tex/latex\base\ot1cmr.fd)
(D:\Programme\MiKTeX\2.9\tex/latex\base\ot1cmss.fd)
(D:\Programme\MiKTeX\2.9\tex/latex\base\ot1cmtt.fd)))

====================================

Local config file fontmath.cfg used

====================================

(D:\Programme\MiKTeX\2.9\tex/latex\base\fontmath.cfg
(D:\Programme\MiKTeX\2.9\tex/latex\base\fontmath.ltx

=== Don't modify this file, use a .cfg file instead ===

(D:\Programme\MiKTeX\2.9\tex/latex\base\omlcmm.fd)
(D:\Programme\MiKTeX\2.9\tex/latex\base\omscmsy.fd)
(D:\Programme\MiKTeX\2.9\tex/latex\base\omxcmex.fd)
(D:\Programme\MiKTeX\2.9\tex/latex\base\ucmr.fd)))

====================================

Local config file preload.cfg used

=====================================

(D:\Programme\MiKTeX\2.9\tex/latex\base\preload.cfg
(D:\Programme\MiKTeX\2.9\tex/latex\base\preload.ltx)) page nos., x-ref,
environments, center, verbatim, math definitions, boxes, title, sectioning,
contents, floats, footnotes, index, bibliography, output,

===========================================

Local configuration file hyphen.cfg used

===========================================

(D:\Programme\MiKTeX\2.9\tex/generic\babel\hyphen.cfg
(D:\Programme\MiKTeX\2.9\tex/generic\babel\switch.def)
(D:\Programme\MiKTeX\2.9\tex/generic\knuth-lib\hyphen.tex)
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\loadhyph\loadhyph-af.tex
EC Afrikaans hyphenation patterns
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\conversions\conv-utf8-ec.tex)
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\patterns\tex\hyph-af.tex))
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\loadhyph\loadhyph-grc.tex
Hyphenation patterns for Ancient Greek
(D:\Programme\MiKTeX\2.9\tex/generic\elhyphen\grahyph5.tex
Hyphenation patterns for Ancient Greek))
(D:\Programme\MiKTeX\2.9\tex/generic\hyphen\zerohyph.tex)
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\loadhyph\loadhyph-hy.tex
No Armenian hyphenation patterns - only for Unicode engines)
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\loadhyph\loadhyph-as.tex
No Assamese hyphenation patterns - only for Unicode engines)
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\loadhyph\loadhyph-eu.tex
EC Basque hyphenation patterns
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\conversions\conv-utf8-ec.tex)
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\patterns\tex\hyph-eu.tex))
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\loadhyph\loadhyph-bn.tex
No Bengali hyphenation patterns - only for Unicode engines)
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\loadhyph\loadhyph-nb.tex
EC Norwegian Bokmal hyphenation patterns
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\conversions\conv-utf8-ec.tex)
(D:\Programme\MiKTeX\2.9\tex/generic\hyph-utf8\patterns\tex\hyph-nb.tex
(

Seems to stop in the middle.


Edit

Today, i tried to work on the problem and did a MikTeX update. I get the following error prompt:

enter image description here

Together with the following error report:

Windows API error 127: Die angegebene Prozedur wurde nicht gefunden.

Details:

dllName="D:\Programme\MiKTeX\2.9\miktex/bin/x64\MiKTeX209-packagemanager.dll"

Side-question: Is there something wrong with the slashes at /bin/?

  • And the outfile refererred to initexmf_admin.log: 2018-12-19 17:43:41,429+0100 ERROR initexmf - sub-process error output has been saved to 'C:\ProgramData\MiKTeX\2.9\miktex\log\miktex-makefmt_2018-12-19-174341.out' 2018-12-19 17:43:41,429+0100 FATAL initexmf - The executed process did not succeed. 2018-12-19 17:43:41,429+0100 FATAL initexmf - Info: fileName="D:\Programme\MiKTeX\2.9\miktex\bin\x64\miktex-makefmt.exe", exitCode="1" – raedma Dec 19 '18 at 16:46
  • Is D: drive a conventional one (like NTFS on usb)? – user170109 Dec 19 '18 at 16:51
  • The system is Windows 7 and D is a partition on the system ssd with NTFS. I used this config for a couple of years without problems on updates. And yes, I installed MikTeX as admin if I remember correctly – raedma Dec 19 '18 at 16:54
  • did you try initexmf --admin --force --mklinks (then again without admin) – user170109 Dec 19 '18 at 17:05
  • I did. Both ways. – raedma Dec 19 '18 at 17:26
0

The problem was not solveable. I ended up re-installing a fresh MikTeX-version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.