2

About once out of every four times that I compile a large LaTeX project (about 780 pages) in TeXShop, the console freezes and stops the compiling. The content of the LaTeX files does not seem to affect the freezing--I can compile exactly the same file 2-3 times in a row with no problem and then the next time or two it freezes, and then I can compile it again a few more times. Where it freezes in the document also seems random--sometimes on page 200, another time on page 779.

There is no error thrown, no warning, nothing--it just stops compiling and waits. The console also does not accept further input at that point. But the rest of TeXShop still continues to work fine, so to recover I just have to recompile (twice, since the aux files are all damaged by this). Since the project is big, compiling takes a while, so this is a bother.

I am running TeXShop version Version 4.21 on a 2015 MacBook Air 2.2 GHz Intel Core i7, with 8GB RAM running Mojave (10.14). But I have had this problem for several months, running earlier versions of MacOS and earlier versions of TeXShop. This also happens on my 2013 iMac, 3.5 GHz Intel Core i7, with 24GB RAM, also running Mojave, but also occured on previous versions of MacOS and previous versions of TeXShop.

The command that TeXShop runs to compile is

pdflatex --file-line-error --synctex=1 book.tex

The problem has not yet occurred in the mac terminal when I run the same pdflatex command there (with TeXShop still up and running), so I don't think it is a TeX problem or memory issue.

I would be grateful for any ideas anyone might have for fixing this.

  • Welcome to StackExchange! This has been discussed on this page tug.org/pipermail/texshop/2018-December/date.html. Unfortunately, the cause seems to remain a mystery. I have experienced this myself. Annoying, but there seems to be no lasting damage. – sgmoye Dec 20 '18 at 17:03
  • The key word is intrmittent. This has made it difficult to analyze. – Herb Schulz Dec 20 '18 at 20:46
  • Please see my comment to the ``answer'' below. Basically, are you using, even only occasionally, anti-virus software like MalwareBytes or bitDefender? – Herb Schulz Dec 26 '18 at 17:37
  • @HerbSchulz: I have experienced a similar issue with smaller files as well, so don't think it is at all related to the size of the file being compiled. And I am not running any anti-virus softare. However, I am running in a Dropbox monitored folder but don't think that is the cause of the issue. I haven't bothered to report is as I have not been able to determine a method to duplicate the issue. – Peter Grill Dec 27 '18 at 0:34
  • @HerbSchulz: Although this problem seems to be not be a TeXShop issue, I have not noticed a similar issue when I run with pdflatex from the command line. The files I process via command line (outside of TeXShop) are different files, so can't totaly rule out it being just a pdflatex issue. – Peter Grill Dec 27 '18 at 0:37
0

There has been an update of TeXShop to version 4.35. This version should fix your problem. You can either update using the TeXShop->Check for Updates… menu item or go directly to https://pages.uoregon.edu/koch/texshop/texshop.html and download it from there.

  • I have not seen the problem occur since I installed the update. Thanks for fixing this! – Tyler Jarvis Sep 20 '19 at 23:28
1

I have had very similar problems using TeXShop to format an 800-page book. I use a new MacBook Pro. These time-consuming problems began to occur when I "upgraded" from High Sierra to Mojave.

The problem is deeper than TeXShop. It is TeX itself that is halting. So switching to a different latex editor does not help.

One could use AppDelete to remove MalwareBytes and other apps that might be interfering with TeX/Mojave. I first deleted MalwareBytes and then downloaded AppDelete, and now I can't get AppDelete to find MalwareBytes so as to remove its unwanted remnants.

  • There have been some comments about a problem with NSTask, in another piece of software, when MalwareBytes or BitDefender (or other anti-virus software?) has been used. Are you using, or have used, either of those items? – Herb Schulz Dec 26 '18 at 14:11
  • With respect, this seems more a question or comment than an answer. Still, in an attempt to help, I can suggest three: TeXnicle, Texpad ($$) and texstudio. Be warned: none of these is anywhere near as polished and easy to use as TeXShop. TeXShop, from the beginning, has been the gold standard for TeX editors IMO (on the Mac, anyway). Hopefully this glitch is a passing annoyance. There is always emacs and AUCTeX, though this is FAR from a straightforward way to go. – sgmoye Dec 26 '18 at 15:31
  • MalwareBytes has a built-in un-install under its Help menu. How can AppDelete determine files to delete if you delete the main file first? Try re-installing MalwareBytes and either use AppDelete or the built-in un-install to clean up everything. Then re-boot to make sure any helper apps are no longer started up. – Herb Schulz Dec 27 '18 at 13:47
  • Please try the latest version of TeXShop, 4.22, which attempts to get around the problem. – Herb Schulz Jan 11 '19 at 17:18
  • I see this same issue with large documents in Version 4.27 (and early ones). Is there a fix as of yet? – John Jun 3 '19 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.