0

I have the following code in my Markdown:

```{latex-fontsize=scriptsize}
    $ ./my-new-application create app_example
    creating app_example
    Generating <path-to-app-src>/new-application/application/config/app_example/application.conf for app_example...
    Application Daemon configuration  written to file: '<path-to-app-src>/new-application/application/config/app_example/application.conf'
    Application Net Name: app_example
    ```

This is generated into the following using pandoc:

\begin{verbatim}
    $ ./my-new-application create app_example
    creating app_example
    Generating <path-to-app-src>/new-application/application/config/app_example/application.conf for app_example...
    Application Daemon configuration  written to file: '<path-to-app-src>/new-application/application/config/app_example/application.conf'
    Application Net Name: app_example
\end{verbatim}

I also have the following in a template.latex file:

\definecolor{codegray}{HTML}{F0F0F0}
\definecolor{framegray}{HTML}{C0C0C0}

\usepackage{lstautogobble}
\lstset{
    breaklines=true,
    breakatwhitespace=false,
    backgroundcolor=\color{codegray},
    frame=none,
    basicstyle=\ttfamily,
    autogobble=true,
    columns=fixed,
    basewidth={0.5em,0.5em},
    frame=tblr,
    framextopmargin=4pt,
    framexbottommargin=4pt,
    rulecolor=\color={framegray},
    literate={”}{{''}}1 {“}{{``}}1 {…}{{...}}1 {‒}{{--}}1
}
\let\verbatim\relax
\lstnewenvironment{verbatim}{}{}

The resulting output has the line starting with Generating... running past the end of the code box. I need to be able to break this up so that the line wraps on a / character. I've tried a bunch of things and none of them have worked. Please help.

  • Please complete your code snippets to be compilable! – Kurt Dec 21 '18 at 20:39
  • 1
    There is an equal sign to much here: rulecolor=\color={framegray}, – Ulrike Fischer Dec 21 '18 at 20:58
  • I found it. I was setting \hyphenpenalty and \exhyphenpenalty to turn off hyphenation, but failed to return them to their default values. Now that I have done this, all is correct. The suggestion by @Kurt caused me to cut this document way down for a MWE. But when I did so, the issue went away. So, I looked at other things I had done and noted these hyphenation changes. Thanks for all your help. – JonBelanger Dec 21 '18 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.