1

I had to uninstall MikTex, because it stopped working properly. Then I failed to install MikTex 2.9 on Windows 10 Pro N (64 bit). The message was: This app can't run on your PC. To find a version for your PC, check with the software publisher.

closed as off-topic by Kurt, Stefan Pinnow, Raaja, Zarko, Phelype Oleinik Jun 3 at 17:23

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    Welcome to TeX SX! Did you try to install as administrator? – Bernard Dec 23 '18 at 22:26
  • I'm the only user of this desktop. Before I uninstalled MiKTeX, I was installing it absolutely in the same way. In my original post, I wrongly indicated OS. It's a 32-bit OS, x64-based processor. – Oleg Dec 26 '18 at 9:34
  • Mmm… Did you download the 32-bit installer? – Bernard Dec 26 '18 at 9:46
  • 1
    you should provide correct data in your question and provide more information about your rights on this PC and if you are behind firewall ... the best is to ask administrator for this PC that (s)he install MikTeX – Zarko Dec 27 '18 at 2:28
  • 4
    I'm voting to close this question as off-topic because it was solved in comment below the answer – Kurt Jun 3 at 16:17
0

Even if hardware can run 64 bits a message such as "This app can't run on your PC" when combined with a secondary message about version such as enter image description here usually indicates trying to load a 64bit app whilst the OS is 32bit. IF the Operating system is 32 bit you need to download MiKTeX from https://ctan.org/tex-archive/systems/win32/miktex/setup/windows-x86

(Personally I prefer the portable version)

  • hm, i have installed MiKTeX 2.9.6880 64-bit, so it exist and it work fine. as installer i use basic-miktex-2.9.6753-x64.exe. installation went smoothly. – Zarko Dec 27 '18 at 1:57
  • @Zarko oleg said "I wrongly indicated OS. It's a 32-bit OS, x64-based processor" – KJO Dec 27 '18 at 2:08
  • in question he claims that have 64-bit windows 10 pro :-( – Zarko Dec 27 '18 at 2:20
  • I too have been caught out frequently by not analysing the OP comments more slowly – KJO Dec 27 '18 at 2:21
  • It perfectly works now with ctan.org/tex-archive/systems/win32/miktex/setup/windows-x86 – Oleg Dec 27 '18 at 10:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.