3

This question already has an answer here:

This question is originally from the discussion under github issue CTeX-org/forum#4.

The similar problems raised by questions

are now nicely solved with the newly updated PGF 3.1, using either luatex 1.07 or 1.09 under Linux (see this issue comment) and Windows (verified by my friend). This is why the current question is tagged duplicate.

But, as stated in this issue comment and the following one, the problem (will explain latter) remains under macOS, even with PGF 3.1.

The problem fixes if I use

  • LuaTeX 1.09, or
  • LuaTeX 1.07 by luatex53 --fmt=lualatex main.tex.

Hence, so far as I know, the problem only remains with macOS, LuaTeX 1.07 (Lua 5.2.4).


A full example

\documentclass{article}
\usepackage[compat=1.1.0]{tikz-feynman}

\begin{document}
\begin{tikzpicture}
  \begin{feynman}
    \diagram [vertical'=a to b] {
      i1 [particle=\(e^{-}\)]
         -- [fermion] a
         -- [draw=none] f1 [particle=\(e^{+}\)],
      a -- [photon, edge label'=\(p\)] b,
      i2 [particle=\(e^{+}\)]
         -- [anti fermion] b
         -- [draw=none] f2 [particle=\(e^{-}\)],
    };
    \diagram* {
      (a) -- [fermion] (f2),
      (b) -- [anti fermion] (f1),
    };
  \end{feynman}
\end{tikzpicture}
\end{document}

The comparison of outputs

image

Version info:

 - TeX Live 2018 on macOS 10.14.2
 - LuaTeX 1.07.0
 - LaTeX2e 2018-12-01

 *File List*
 article.cls    2018/09/03 v1.4i Standard LaTeX document class
  size10.clo    2018/09/03 v1.4i Standard LaTeX file (size option)
tikz-feynman.sty    2016/02/05v1.1.0Feynman diagrams with TikZ
    tikz.sty    2019/01/05 v3.1 (3.1)
     pgf.sty    2019/01/05 v3.1 (3.1)
  pgfrcs.sty    2019/01/05 v3.1 (3.1)
everyshi.sty    2001/05/15 v3.00 EveryShipout Package (MS)
  pgfrcs.code.tex
 pgfcore.sty    2019/01/05 v3.1 (3.1)
graphicx.sty    2017/06/01 v1.1a Enhanced LaTeX Graphics (DPC,SPQR)
  keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
graphics.sty    2017/06/25 v1.2c Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    2016/01/03 v1.10 sin cos tan (DPC)
graphics.cfg    2016/06/04 v1.11 sample graphics configuration
  luatex.def    2018/01/08 v1.0l Graphics/color driver for luatex
  pgfsys.sty    2019/01/05 v3.1 (3.1)
  pgfsys.code.tex
pgfsyssoftpath.code.tex    2019/01/05 v3.1 (3.1)
pgfsysprotocol.code.tex    2019/01/05 v3.1 (3.1)
  xcolor.sty    2016/05/11 v2.12 LaTeX color extensions (UK)
   color.cfg    2016/01/02 v1.6 sample color configuration
 pgfcore.code.tex
pgfcomp-version-0-65.sty    2019/01/05 v3.1 (3.1)
pgfcomp-version-1-18.sty    2019/01/05 v3.1 (3.1)
  pgffor.sty    2019/01/05 v3.1 (3.1)
 pgfkeys.sty    
 pgfkeys.code.tex
 pgfmath.sty    
 pgfmath.code.tex
  pgffor.code.tex
    tikz.code.tex
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
 pgfopts.sty    2014/07/10 v2.1a LaTeX package options with pgfkeys
supp-pdf.mkii
epstopdf-base.sty    2016/05/15 v2.6 Base part for package epstopdf
infwarerr.sty    2016/05/16 v1.4 Providing info/warning/error messages (HO)
  grfext.sty    2016/05/16 v1.2 Manage graphics extensions (HO)
kvdefinekeys.sty    2016/05/16 v1.4 Define keys (HO)
 ltxcmds.sty    2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
kvoptions.sty    2016/05/16 v3.12 Key value format for package options (HO)
kvsetkeys.sty    2016/05/16 v1.17 Key value parser (HO)
etexcmds.sty    2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)
pdftexcmds.sty    2018/09/10 v0.29 Utility functions of pdfTeX for LuaTeX (HO)
   ifpdf.sty    2018/09/07 v3.3 Provides the ifpdf switch
epstopdf-sys.cfg    2010/07/13 v1.3 Configuration of (r)epstopdf for TeX Live
 ***********

marked as duplicate by Henri Menke, Stefan Pinnow, TeXnician, Phelype Oleinik, Seamus Jan 9 at 12:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I believe it is the same issue as this one. – marmot Dec 25 '18 at 19:39
  • @marmot You are right. I apologize for not doing enough searching before asking. – Johannes Z Dec 25 '18 at 19:45
  • Now there is an answer. Of course, if it does not help you, I will be happy to retract my duplicate vote. – marmot Jan 1 at 23:28
  • 1
    @marmot With PGF 3.1, the problem is solved under Linux (verified by you here) and Windows (verified by my friend), but not macOS (double checked by my friend and myself). Hence this question is not solved for users of macOS, including myself. – Johannes Z Jan 9 at 2:53
  • 1
    I voted for reopening because the problem persists on MacOS (I explicitly confirm that). – marmot Jan 9 at 3:16