1

This question already has an answer here:

I just upgraded my texlive and can no longer use tabu spread when floatrow is loaded.

It seems that array.sty might be the problem as this is the only package to change recently. I tried downgrading array.sty from [2018/11/13 v2.4j] to [2018/04/30 v2.4h], the MWE compiled without problems.

I am working on a template, so I have no control over package version.

Can anyone suggest a workaround?

MWE

\documentclass{article}
\usepackage{floatrow}
\usepackage{tabu}
\listfiles
\begin{document}

\begin{tabu} spread 0pt {|X|}
  anything \\
\end{tabu}

\end{document}

It yields:

! Missing } inserted.
<inserted text>
                }
l.9   \end{tabu}

File versions in use:

 article.cls    2018/09/03 v1.4i Standard LaTeX document class
  size10.clo    2018/09/03 v1.4i Standard LaTeX file (size option)
floatrow.sty    2008/08/02 v0.3b floatrow: float package extension
  keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
caption3.sty    2018/09/12 v1.8c caption3 kernel (AR)
    tabu.sty    2011/02/26 v2.8 - flexible LaTeX tabulars (FC)
   array.sty    2018/11/13 v2.4j Tabular extension package (FMi)
varwidth.sty    2009/03/30 ver 0.92;  Variable-width minipages
   color.sty    2016/07/10 v1.1e Standard LaTeX Color (DPC)
   color.cfg    2016/01/02 v1.6 sample color configuration
   xetex.def    2017/06/24 v5.0h Graphics/color driver for xetex

marked as duplicate by Ulrike Fischer, Stefan Pinnow, TeXnician, Mensch, Community Dec 26 '18 at 10:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged or ask your own question.