2

The font in my TeXmaker window is quite small and therefore hard to read.

screenshot of TeXmaker window with small font

Is there a way to make it bigger and easier on the eyes? I would also love to know why the font became so small in the first place.

4
  • 2
    Just have a look at the options. Under "Editor". Dec 27, 2018 at 8:31
  • I tried to reword your question to make it easier to understand and avoid confusion. I hope I did not change the intention of what you were asking for. If so, please roll back the edit or tweak it.
    – moewe
    Dec 27, 2018 at 8:33
  • 1
    The font or the icons?
    – CarLaTeX
    Dec 27, 2018 at 8:35
  • It looks like you are not using the current (latest) version of TeXmaker - TeXmaker 5.0.3. In that version the size of the icons or text is much better.
    – user156344
    Dec 27, 2018 at 9:52

4 Answers 4

5

If I understand correctly, you are talking about the font of the application interface, not that of the latex content that you type in. For the latter, see Bernard's answer. For the former, I had the same problem using TexMaker 5.0.3 on Windows 10 Education version 1803. As suggested on this Windows support webpage, the problem might be due to the use of a high-dpi device (monitor in my case). Playing around with the solution suggested in section 'Workaround' > 'Change application properties' of the same webpage, here is what worked for me (see pictures of steps 1. to 3. and step 4.):

  1. In Explorer or on the Start menu, right-click the application name, select 'Properties'
  2. In the 'Properties' window, select the 'Compatibility' tab
  3. Under 'Settings', click 'Change high DPI settings'
  4. In the new window (also called 'Properties'), under 'High DPI scaling override', tick the box 'Override high DPI scaling behavior. Scaling performed by: System'.

Hope this helps.

2

As an image can be more explicit than lengthy explanations, I'll expand on the 1st comment with a screenshot of the Options > TeXmaker configure menu: just change the editor font size in the relevant form:

enter image description here

0

As pointed out you appear to be using Texmaker version 4.

There is no direct setting in Version 4 (you would need to change Windows compatibility settings per application) DPI awareness was added to Texmaker in version 5. However in Version 5 this is down to a DPI aware setting in QT which can catch new or update users out.

For Texmaker 5 your start-up setting (shortcut) needs to reflect your hardware settings and the simplest way to test is start Texmaker from a shortcut with a command such as

Texmaker -dpiscale 1.5

Then adjust up or down as you wish. However a lot of trial and error may be needed to get a setting that looks reasonable for some of the button icons down the centre and bottom left.

Here is mine at 1.0 and 1.5 enter image description here

0

There are two different places to adjust font sizes in TexMaker:

  • Font sizes for your script are adjusted as indicated above.

  • Menu font sizes on the other hand can be adjusted through Options > Change Interface Font.

Unfortunately, there seam to be problems with font sizes in Texmaker menus, in particular on high definition monitors (I am using Ubuntu 18.04). None of the above adjustments control font sizes for menu items like "Quick Build", "View PDF" and some others. Also making menu font too big could make font in the deeper menus too big for the designated boxes.

1
  • 1
    Welcome to TeX.SE! Can you add screenshots of the two places to adjust font sizes ...
    – Mensch
    Mar 19, 2019 at 0:32

Not the answer you're looking for? Browse other questions tagged .