0

I need to write an article concerning knots, so I want to use the knot package in xy

Adding \usepackage[knot]{xy} to the preamble works fine, until I also draw diagrams (not knot diagrams) using xymatrix. Then Lyx says there is a clash because it automatically loads xy for xymatrix and it clashes with the preamble.

I tried adding "knot" to the document class options, and also tried adding PackageOptions xy knot in the local layout.

I also tried to change all Math Options to 'do not load' in order to specify my packages myself in the preamble.

Nothing works. I am using Lyx 2.3.0.

Please help.

  • Try to load everything: \usepackage[all]{xy} – Sigur Dec 27 '18 at 13:28
  • Thank you - that is what Lyx does automatically when it encounters the xymatrix instance. Apparently, "all" does include "knot". – Ori Rosenstein Dec 27 '18 at 13:31
  • Can you please give us a simple short but fully compilable example that shows the problem? – Thruston Dec 27 '18 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.