3

In the following example, using fnpct for the biblatex autocite command causes unwanted whitespace when a period occurs directly after the the quote.

\documentclass{article}
\usepackage[ngerman]{babel}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
    @article{greenwade93,
        author  = "George D. Greenwade",
        title   = "The {C}omprehensive {T}ex {A}rchive {N}etwork ({CTAN})",
        year    = "1993",
        journal = "TUGBoat",
    }
    @book{goossens93,
        author    = "Michel Goossens and Frank Mittelbach and Alexander Samarin",
        title     = "The LaTeX Companion",
        year      = "1993",
    }
\end{filecontents}

\usepackage{csquotes}
\usepackage[backend=biber,style=authoryear-ibid,date=year,autocite=footnote,giveninits=true]{biblatex}

\SetCiteCommand{\autocite} % used by csquotes

\usepackage{fnpct}
\AdaptNoteOpt\autocite\multfootcite

\bibliography{\jobname}
\begin{document}
    \null
    \vfill
    \blockcquote[see][123]{greenwade93}{Famous quote}. But the period causes an unwanted space to appear.
    \blockcquote[see][123]{greenwade93}{Which is fixed by moving the period inside the quotation.} See?

    The problem is caused by \texttt{fnpct}.

    \texttt{fnpct} is needed to quote multiple authors at once, but in separate footnotes\autocite{greenwade93}\autocite{goossens93}
\end{document}

enter image description here

Is it possible to configure fnpct to not add space between quotation mark and period?

3

As far as I can see the issue here is that handing control of \autocite over to fnpct destroys \autocite's ability to remove preceding whitespace. With biblatex's definition

Lorem \autocite{sigfridsson}.

and

Lorem\autocite{sigfridsson}.

produce the same output since \autocite issues \unspace. But as soon as fnpct takes the reins, those two lines behave differently.

Usually this is not going to be much of a problem since you probably never leave a space before \footnote or \autocite anyway. But with the default settings of csquotes commands like \blockcquote leave a space before they call \autocite (assuming the usual definition of biblatex's citation commands that make sense: many commands need a space in front of the \...cite so they don't stick to the text before and \footcite, \autocite and friends can deal with preceding space just fine). You can explicitly tell csquotes not to leave a space before calling the citation command by redefining \mkccitation, cf. also page 30 of the csquotes documentation,

\renewcommand{\mkccitation}[1]{#1}

The full MWE

\documentclass{article}
\usepackage[ngerman]{babel}
\usepackage{csquotes}
\usepackage[backend=biber,style=authoryear-ibid,date=year,autocite=footnote,giveninits=true]{biblatex}

\SetCiteCommand{\autocite}
\renewcommand{\mkccitation}[1]{#1}

\usepackage{fnpct}
\AdaptNoteOpt\autocite\multfootcite

\addbibresource{biblatex-examples.bib}
\begin{document}
    \null
    \vfill
    \blockcquote[see][123]{sigfridsson}{Famous quote}. But the period causes an unwanted space to appear.
    \blockcquote[see][123]{sigfridsson}{Which is fixed by moving the period inside the quotation.} See?

    The problem is caused by \texttt{fnpct}.

    \texttt{fnpct} is needed to quote multiple authors at once, but in separate footnotes\autocite{sigfridsson}\autocite{sigfridsson}

  Lorem \autocite{sigfridsson}.

  Lorem\autocite{sigfridsson}.
\end{document}

then gives the expected output.

Output of the example. The <code>fnpct</code>-controlled footnotes don't suppress previous space. <code>\blockcquote</code> displays as intended again.

I'm still having trouble uploading output pictures. Sorry. If you would like to add images of the result, feel free to do so. See https://v1.overleaf.com/read/hgvsffpjwjbt for a demo.

  • Thank you @moewe for clarifying what's happening here – Stefan Dec 28 '18 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.