3

In a thesis, I am using \footnote and \footcite[][]{} (as well as \footcites[][]{}[][]{}) simultaneously to add footnotes and citations.

However, I am unable to align the footnotes uniformly. The space between the number and the text in \footnote is different than the space in \footcite[][]{}. Also, I would like to make sure that multiple-line footnotes and citations do not hang under the number.

Any help would be great, and thanking you all in advance.

Here is the class file of the thesis.

\NeedsTeXFormat{LaTeX2e}
\ProvidesClass{these_Eva}

% This is an adaptatin of the BFH template by bernl1
% Author: dhs1 

\DeclareOption*{\PassOptionsToClass{\CurrentOption}{memoir}}

\ProcessOptions

\LoadClass{memoir}

\RequirePackage{fancyhdr}

% Load Standard Packages:
%---------------------------------------------------------------------------
\usepackage{stix}
\usepackage[T1]{fontenc}                                            %codage de sortie adapté au français
%\usepackage[standard-baselineskips]{cmbright}
\usepackage{babel}                                              % language
%\usepackage{inputenc}
%\usepackage{csquotes}                                                  % for use of biblatex
\usepackage{textcomp}                                                   % additional symbols
\usepackage{enumitem}                                                   % for intertext in lists
\usepackage{fancyhdr}                                                   % simple manipulation of header and footer 
\usepackage{etoolbox}                                                   % color manipulation of header and footer
\usepackage{graphicx}                                                   % integration of images
\usepackage{float}                                                      % floating objects
\usepackage{subcaption}
%\usepackage{caption}                                                   % for captions of figures and tables --> not needed with memoir class
\usepackage{booktabs}                                                   % package for nicer tables
\usepackage{tocvsec2}                                                   % provides means of controlling the sectional numbering
%\usepackage{titlesec}                                      % 
\usepackage{shorttoc}
\usepackage[hyphens]{url}
%[Himanshu] added [hyphens] in the above line.

%---------------------------------------------------------------------------
% Set up page dimension
%---------------------------------------------------------------------------
\setstocksize{225mm}{155mm}
\settrimmedsize{\stockheight}{\stockwidth}{*}
\setlrmarginsandblock{40mm}{20mm}{*}                %\setlrmarginsandblock{⟨spine⟩}{⟨edge⟩}{⟨ratio⟩}
\setulmarginsandblock{23mm}{25mm}{*}            % --> because headers and footers are included   \setulmarginsandblock{⟨upper⟩}{⟨lower⟩}{⟨ratio⟩}
%%% Alternatively: %%%
%\settypeblocksize{*}{115mm}{1.512}         % \settypeblocksize{⟨height⟩}{⟨width⟩}{⟨ratio⟩}
%\setlrmargins{20mm}{*}{*}
%\setulmargins{30mm}{*}{*}

%----------%% is defined accordingly to word-Vorlage from Schultess: -----------------
\setheaderspaces{12.25mm}{*}{1}                 % \setheaderspaces{⟨headdrop⟩}{⟨headsep⟩}{⟨ratio⟩} (above and below the header)
\setheadfoot{13pt}{12.5mm}
\setmarginnotes{6mm}{8mm}{10pt} 
\sideparmargin{outer}   

%\setfootins{⟨length for normal⟩}{⟨length for minipage⟩}
%When footnotes are added to the text block they are added \skip\footins below the text. Since this is a skip it usually needs special syntax to change it. Instead we have provided an interface to set it. 5 The default sizes are \bigskipamount.

%--------------------------------------------------------------------------
% Fonts and text size, headers and footers content
%--------------------------------------------------------------------------
%[Himanshu] Changed the font face to Linux Libertine. Remove the next three lines to restore to old font.
\usepackage{libertine}
\usepackage{libertinust1math}
\usepackage[T1]{fontenc}

\rmfamily %Roman family

\pagestyle{ruled}
\aliaspagestyle{chapter}{ruled}             % header and footers d'une page chapitre sont comme dans le pagestyle défini. (Sans ça on aurait le style "plain")


%-------------------------- Headings -----------------------
% part:
% chapter:
%[Himanshu] Changed the font size from \huge to \Huge. Please change it back to restore to original.
%[Himanshu] Changed the font face to SANS SERIF (\sffamily) instead of previously assigned SERIF (\normalfont). Replace in the following three lines to change them back.
      \makechapterstyle{lae}{ 
      \clearpage
       \renewcommand{\chapnamefont}{\sffamily\Huge\bfseries}
     \renewcommand{\chapnumfont}{\sffamily\Huge\bfseries}       % per default same value as chapnamefront
     \renewcommand{\chaptitlefont}{\sffamily\Huge\bfseries}
      \renewcommand{\chapterheadstart}{}
     \renewcommand{\afterchapternum}{:\chapternamenum}        % \midchapskip space between number and title
     \setlength{\beforechapskip}{6.4mm}
    \setlength{\afterchapskip}{2.1mm}       % 2.1mm = 6pt
    }
    \headstyles{bringhurst}
     \chapterstyle{lae}

 % section:
%[Himanshu] Changed the font size from \large to \LARGE. Change it back to restore to original setting.
\renewcommand{\thesection}{\Roman{section}}
    \setlength{\beforesecskip}{4.2mm}   
    \setlength{\aftersecskip}{2.1mm}
      %\setSindent{⟨length⟩}        
   \setsecheadstyle{\LARGE\bfseries\raggedright}%

 % sub-section:
%[Himanshu] changed the font face to \bfseries instead of \normalfont. Change to \normalfont to restore the original settings.
%[Himanshu] added a dot after the sub-section number. Remove the point after \arabic{subsection} to change it to the original settings.
  \renewcommand{\thesubsection}{\arabic{subsection}.}
    \setlength{\beforesubsecskip}{3.8mm}    
    \setlength{\aftersubsecskip}{2.1mm}     
   \setsubsecheadstyle{\Large\bfseries\raggedright}%

% sub-sub section: 
%[Himanshu] added \mdseries to set to medium font face. Remove \mdseries to set it back to original settings.
%[Himanshu] added a dot after the subsubsection number. Remove the point after \arabic{subsubsection} to chnge it to the original settings.
  \renewcommand{\thesubsubsection}{\arabic{subsection}.\arabic{subsubsection}.}
    \setlength{\beforesubsubsecskip}{11pt}  
    \setlength{\aftersubsubsecskip}{2.1mm}      
   \setsubsubsecheadstyle{\large\mdseries\slshape\raggedright}%

% paragraph
%[Himanshu] added paranthesis around the paragraph number. Remove '(' and ')' around \alph{paragraph} to change it back to the initial settings.
%[Himanshu] added the slanting font-face. Remove \slshape to restore to the original settings.
  \renewcommand{\theparagraph}{(\alph{paragraph})}
    \setlength{\beforeparaskip}{3.9mm}  
    \setlength{\afterparaskip}{2.1 mm}
     \setparaindent{0pt}        
   \setparaheadstyle{\normalsize\bfseries\slshape\raggedright}%

 % sub-paragraph
    \setlength{\beforesubparaskip}{4.2mm}   
    \setlength{\aftersubparaskip}{2.1 mm}       
   \setsubparaheadstyle{\normalsize\bfseries\raggedright}%

% lists:

%-------------------------- Paragraphs -----------------------
\setlength{\parindent}{0pt}             % no indent for new paragraphs
\setlength{\parskip}{3.2mm}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%




% Package to facilitate placement of boxes at absolute positions
%---------------------------------------------------------------------------
\usepackage[absolute]{textpos}
\setlength{\TPHorizModule}{1mm}
\setlength{\TPVertModule}{1mm}
%---------------------------------------------------------------------------                    



% Hyperref Package (Create links in a pdf)
%---------------------------------------------------------------------------
\usepackage[
    pdftex,ngerman,bookmarks,plainpages=false,pdfpagelabels,
    backref = {false},                                                  % No index backreference
    colorlinks = {true},                                                % Color links in a PDF
    hypertexnames = {true},                                             % no failures "same page(i)"
    bookmarksopen = {true},                                             % opens the bar on the left side
    bookmarksopenlevel = {0},                                           % depth of opened bookmarksa
    linkcolor = {black},                                            % Color of Links
    citecolor = {black},                                            % Color of Cite-Links
    urlcolor = {black},                                             % Color of URLs
]{hyperref}

\urlstyle{sf}

\endinput

I am also attaching the snapshot of the current output.

Current Output

And the desired result.

Desired result

Minimum working example with bibliography :

\documentclass[
    french,
    10 pt,                  % fontsize 
    openright
]{class/these_Eva}              % these-droit class
\usepackage[utf8]{inputenc}
\usepackage[style=geschichtsfrkl,backend=biber,sorting=nyt]{biblatex}
\addbibresource{\thesis.bib}
\usepackage{filecontents}

\begin{filecontents}{\thesis.bib}
@article{wybitul_betriebsvereinbarungen_nodate-1,
    title = {Betriebsvereinbarungen und § 32 {BDSG}: {Wie} geht es nach der {DS}-{GVO} weiter?},
    language = {de},
    author = {Wybitul, Tim and Sörup, Thorsten and Pötters, Stephan},
    pages = {6},

}

@book{gola_eu-ds-gvo_2016-1,
    title = {{EU}-{DS}-{GVO} {EU}-{Datenschutz}-{Grundverordnung}},
    isbn = {978-3-406-69543-8},
    language = {German},
    author = {Gola, Peter and Gola, Peter and Klug, Christoph and Nguyen, Alexander and Piltz, Carlo and Pötters, Stephan and Schulz, Sebastian and Wybutil, Tim and {Verlag C. H. Beck}},
    year = {2016},
    annote = {OCLC: 941670883}
}
\end{filecontents}

\begin{document}

Some text\footcite[Pre-text][Post-text]{wybitul_betriebsvereinbarungen_nodate-1}, then some more text\footcite[][]{gola_eu-ds-gvo_2016-1}, and now a normal footnote\footnote{Hello world!}.

\printbibliography

\end{document}
  • I have so far tried the \usepackage[hang]{footmisc} but it doesn't work. Probably there is a conflict with the hyperref or fancyhdr package?? – Himanshu Verma Dec 29 '18 at 17:47
  • 2
    I think there is more than one thing going wrong here! What bibliography style are you using? – Paul Stanley Dec 29 '18 at 19:23
  • Your documentclass is based on memoir, so you should use the mechanisms provided there to format your footnotes. Also please add a minimal working example with bibliography (MWEB) – DG' Dec 29 '18 at 20:35
  • I am using the bibliography style defined in package geschichtsfrkl. It is defined as follows: \usepackage[style=geschichtsfrkl,backend=biber,sorting=nyt]{biblatex} – Himanshu Verma Dec 29 '18 at 21:16
  • Thanks @DG, I will dig into the memoir document class. I have edited my post to provide a MWEB. – Himanshu Verma Dec 29 '18 at 21:34
3

There are many problems with your these_Eva.cls: It's based on memoir and still loading packages that are incompatible with or emulated by it (like caption and fancyhdr). Also you are using \usepackage in the class file, instead of \RequirePackage and so on.

However, the following code snippet will get you the desired result with memoir, once you have cleaned up these_Eva.cls:

\footmarkstyle{#1.\hfill}
\setlength{\footmarkwidth}{1.8em}
\setlength{\footmarksep}{0em}

enter image description here

  • 3
    Great. But do yourself a favor: Don't use these_Eva.cls. It's easier to set up a new document according to your specifications, than to trouble shoot that thing. – DG' Jan 1 at 18:40
1

It took sometime but I figured out the issue.

Two things solved the problem. First, to add a space between the footnote mark (number) and the text, I added the following code in the .cls file.

\usepackage[supstfm=libertinesups]{superiors}
\usepackage{fnpct}

\usepackage{scrextend}

\newlength{\fmwidth}
\AtBeginDocument{%
  \settowidth{\fmwidth}{\footnotesize 0000.}%
  \addtolength{\fmwidth}{3mm}%
  \deffootnote[\fmwidth]{\fmwidth}{1em}{\thefootnotemark.\hspace{3mm}}%
}

Next, to remove the indent in the first line of the \footcite[][]{}, I found this article very useful, on \fullcite without indent in Biblatex.

  • 1
    Please don't "solve" problems with a memoir-based document class by adding a KOMA-Script library. Choose either memoir or KOMA-Script and stick to it. Better even: fix the bugs in the original class, which were caused by using incompatible packages in the first place. If you keep mixing stuff like this, things will keep breaking at unexpected places. – DG' Jan 1 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.