1

As pointed out in the accepted answer there is a difference between the standard footnote style and the German footnote style.

The code from below gives some strange space in-between two citation (as marked in red). How can I avoid that?

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{\jobname.bib}

@incollection{incollection,
    author       = {Peter Farindon}, 
    title        = {The title of the work},
    booktitle    = {The title of the book},
    publisher    = {The name of the publisher},
    year         = 1993,
    pages     ={10},
}

@incollection{a,
    author       = {Peter Farindon}, 
    title        = {The title of the work},
    booktitle    = {The title of the book},
    publisher    = {The name of the publisher},
    year         = 1993,
    pages     ={10},
}

@incollection{b,
    author       = {Peter Farindon}, 
    title        = {The title of the work},
    booktitle    = {The title of the book},
    publisher    = {The name of the publisher},
    year         = 1993,
    pages     ={10},
}

\end{filecontents}

\documentclass{article}
\usepackage[style=verbose]{biblatex}
\usepackage[ngerman]{babel}
\usepackage{csquotes}

\makeatletter
\renewcommand{\@makefntext}[1]{%
  \setlength{\parindent}{0pt}%
  \begin{list}{}{%
    \setlength{\labelwidth}{1.5em}% <===================================
    \setlength{\leftmargin}{\labelwidth}%
    \setlength{\labelsep}{3pt}%
    \setlength{\itemsep}{0pt}%
    \setlength{\parsep}{0pt}%
    \setlength{\topsep}{0pt}%
%   \setlength{\rightmargin}{0.2\textwidth}%
    \footnotesize}%
  \item[\@makefnmark\hfil]#1%
  \end{list}%
}
\makeatother


\addbibresource{\jobname.bib}
\begin{document}
    Let's cite!  \footcite{incollection} \footcite{a} \footcite{b}
    \printbibliography
\end{document}
  • 1
    have you tried playing with the \topsep parameter? Setting it to a negative value, eg -2pt should do the trick – Wiebke Jan 2 at 12:41
  • 3
    In that case setting \setlength{\partopsep}{0pt} directly is probably nicer than trying to cancel out \partopset with a negative \topsep. – moewe Jan 2 at 12:53
  • 1
    I too suggested that to make "\partopsep" to 0pt, instead of changing "\topsep" as a negative value – MadyYuvi Jan 2 at 13:17
3

I'm not entirely sure if this list environment is the conceptually best way to format footnotes, but since many environments are based on \list or \trivlist this is probably not too outlandish.

You will want to set the length \partopsep to 0 as well. See \topsep, \itemsep, \partopsep and \parsep - what does each of them mean (and what about the bottom)? for more on all the lengths involved.

I don't think it is necessary to set \parindent to zero, so I dropped that line. I also dropped the \setlength{\parsep}{0pt} because it would otherwise be quite challenging to make out the beginning of a new paragraph in a footnote.

\documentclass{article}
\usepackage[ngerman]{babel}
\usepackage{csquotes}
\usepackage[nopar]{kantlipsum}

\makeatletter
\renewcommand{\@makefntext}[1]{%
  \begin{list}{}{%
    \setlength{\labelwidth}{1.5em}%
    \setlength{\leftmargin}{\labelwidth}%
    \setlength{\labelsep}{3pt}%
    \setlength{\itemsep}{0pt}%
    \setlength{\partopsep}{0pt}%
    \setlength{\partopsep}{0pt}%
    \setlength{\topsep}{0pt}%
    \footnotesize}%
  \item[\@makefnmark\hfil]#1%
  \end{list}%
}
\makeatother

\begin{document}
 Lorem\footnote{\kant[1]} dolor\footnote{\kant[2]\par\kant[3]} amet\footnote{\kant[4]}  amet\footnote{\kant[5]}.
\end{document}

Screenshot of the MWE and its footnotes. There is no excessive space between footnotes. Paragraphs within footnotes are separated by vertical space.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.