1

I have the following piece of Latex code. I receive this warning:

Package pstool Warning: No file "epsfigure.tex" or "epsfigure-psfrag.tex" can be found that may contain macros for "epsfigure.eps" on input line 24.

while I have put the .eps figure in the directory. What I should do to get rid of this warning that I see in all my latex files?

Thanks a lot

\documentclass[journal]{IEEEtran}
\usepackage{cite,graphicx,amsmath,amssymb,psfrag,bm}
\usepackage{mathabx}
\usepackage{pgfplots}
\usepackage{tikz}
\pgfplotsset{compat = newest}
\usepackage{epstopdf}
\epstopdfsetup{update} % only regenerate pdf files when eps file is newer
\usepackage{pstool}
\usepackage{subcaption}

\begin{document}
  Some text... Suddenly a figure!

\begin{figure}[!ht]
\centering
\begin{subfigure}{1\columnwidth}
 \centering
\psfragfig[width=1\columnwidth]{epsfigure}{
\psfrag{1}[c][c][1.]{$w$}
 \psfrag{2}[c][c][1.]{$g$}
 \psfrag{3}[c][c][1.]{$l$}
 \psfrag{4}[c][c][1.]{$s$}
}\caption{}\label{fig:final_1}
\end{subfigure}

\begin{subfigure}
  \centering
  \includegraphics[width=1\columnwidth]{test01}
  \caption{} \label{fig:final_3}
  \end{subfigure}
\caption{action.}
\label{fig:final}
\end{figure}

\end{document} 
4
  • Into a directory or a same folder?
    – Sebastiano
    Jan 7, 2019 at 11:55
  • In the same folder
    – Yousef Vh
    Jan 7, 2019 at 15:33
  • But the files are .eps or .ps?
    – Sebastiano
    Jan 9, 2019 at 0:00
  • they are .eps figures.
    – Yousef Vh
    Jan 10, 2019 at 18:05

1 Answer 1

0

There are afaik know three options

  • change from pdflatex to (dvi)latex
  • add an empty file imx/testfig.tex
  • add an empty file imx/testfig-psfrag.tex

I assume it is a feature not a bug, you could theoretically use macros in one of imx/testfig.tex or imx/testfig-psfrag.tex, which might be necesarry, since everything you define in the document will not be accessible in the graphics (e.g. if you define a command in the document you can not use this command in psfragfic in pdflatex (differently to (dvi)latex)).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .