I use Texstudio and Miktex on Win 7 as a portable version.

Today i updated my miktex-packages and everything worked fine except the "\usepackage{tikz}" command.

I made a fresh reinstall with the newest versions of miktex and texstudio, opened my latex-document and compiled it. Miktex installed all missing packages on-the-fly except pgf/tikz, wich gave an error instead. I installed it manually in the package manager but texstudio still says "File "tikz.sty" not found".

Unfortunately I have to use the portable version, because I don't have any admin rights. The last time I worked on that document, everything worked fine.

Any ideas?

  • 3
    The miktex package pgf is broken, it doesn't contain any files. Add an issue to github.com/MiKTeX/miktex-packaging – Ulrike Fischer Jan 7 '19 at 13:11
  • related : MikTex doesn't install tikz – AndréC Jan 7 '19 at 13:56
  • 2
    Please report package or distribution errors always directly to the developer over its support contact channel (website, forum, whatever they have for this). Stackexchange is not a bug tracker. – Martin Scharrer Jan 7 '19 at 14:40
  • 5
    I'm voting to close this question as off-topic because this is a bug in MikTeX packaging and should be reported on the bugtracker (which it already has been github.com/MiKTeX/miktex-packaging/issues/80). – Henri Menke Jan 7 '19 at 21:42
  • 3
    I voted to leave this open -- at least for the next few days. There will probably be more questions about this problem and we can easily mark them as duplicate of this question. Also user with this problem can better find this questions and follow the link from Ulrike Fischers answer to get up to date information from the bug report. – samcarter_is_at_topanswers.xyz Jan 7 '19 at 22:37

The MikTeX package pgf is broken, it doesn't contain any files.

In such cases the right thing to do is to check the issues at https://github.com/MiKTeX/miktex-packaging/issues and to add one if needed.

This has already been done: https://github.com/MiKTeX/miktex-packaging/issues/80


It is fixed after todays update

  • 2
    Yes, but that is already pointed out in the comment section of the question. – user156344 Jan 8 '19 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.