3

I'm trying to achieve something like this layout, a Bible text with verse numbers in the margins:

Bible original

In addition, I need footnotes linked to the verse numbers. I'm trying to make that work in reledmac, setting line numbers to reflect the verses:

\documentclass{article}
\usepackage[total={2.5in, 2.7in}]{geometry}
\usepackage{polyglossia,fontspec,xunicode}
\usepackage{libertine}
\usepackage[series={A},noend,noeledsec,nofamiliar,noledgroup]{reledmac}

\begin{document}
  \firstlinenum{1}
  \linenumincrement{1}
  \beginnumbering
  \pstart
    \setline{4}Baptizabat Ioannes in solitudine, et emendationis vitae baptisma publicabat ad peccatorum veniam,\setline{5} ad eumque proficiscebatur tota Iudaea regio ac Hierosolymitani, et ab eo baptizabantur omnes in Iordane fluvio, confitentes peccata sua.\setline{6} Erat autem Ioannes indutus camelinis pilis, lateribus pelliceo cingulo cinctis, vescebaturque locustis et \edtext{melle silvestri}{\Afootnote{quod mel Ioannes non in horto vel apiario colebat, sed in locis desertis inveniebat.}},\setline{7} atque huiusmodi verbis publice docebat: “Venit quidam post me, adeo me praestantior, ut ego non sim dignus qui eius calceorum corrigiam pronus solvam.\setline{8} Ego quidem vos aqua baptizavi, at is vos sancto Spiritu baptizabit.”
  \pend
  \endnumbering
\end{document}

The one step that I can't figure out is to show the "line" (verse) numbers only on the lines where a new verse begins, so that subsequent lines of the same verse don't display the next verse number:

enter image description here

If this is impossible, there are two other methods I can think of:

  1. Use \hidenumbering within the text of every line that shouldn't show a new verse number. But this is cumbersome, and changing the text or layout would mess it up.
  2. Better: instead of line numbers, use a \marginnote for each verse number. But this would require setting \linenum manually for each footnote. Not a lot of extra work, but it seems like working around reledmac in a way that I'm not sure is necessary.

So, is there a way to auto-hide all line numbers except on lines with \setline or some other command?

  • If you search here for "bible" you will find lots of packages and options for typesetting verses. I don't know if any of them use reledmac, however. – John Kormylo Jan 7 at 16:48
  • formally, line numbering resetting can be ok for you, as you can have multiple verse in the same line. The most close to your problem will be \linenumannotation, but I need to change one behavior of this feature. – Maïeul Jan 7 at 20:01
  • I have found a way. I need to code something in reldmac, and will answer you. – Maïeul Jan 7 at 21:42
4

Reledmac provides a useful tools for you: the line number annotation. It allows to add arbitrary annotation to any line number, annotation which will be typeset in the critical footnotes.

However, this feature was initially conceived for poetry, and the the line number are reset at each line. But I have just send on CTAN a new version of reledmac (2.29.0), which allow to disable this feature.

In your case, you must also to disable the real line number, and just keep the annotation.

Furthermore, you need to not printing two times the annotation when it is identical. The version 2.30.0 of reledmac, send on CTAN the 22 january 2019, add a new hook, \Xnoidenticallinenumannotation, to do that.

So here, the code, with commentary, to solve your issue

\documentclass{article}
\usepackage[total={2.5in, 2.7in}]{geometry}
\usepackage{polyglossia,fontspec,xunicode}
\usepackage{libertine}
\usepackage[noresetlinenumannotation, series={A}, noend,noeledsec,nofamiliar,noledgroup]{reledmac}%Not resetting line number annotation
\newcommand{\bv}[1]{\linenumannotation{#1}}%Biblical verse are managed as line annotation
\makeatletter
\Xwraplinenumannotation{\@firstofone}%We just typeset the annotation, without any formatting
\renewcommand{\linenumrep}[1]{}% We don't typeset the real line number.
\makeatother
\Xnoidenticallinenumannotation% Don't typeset to identical line number annotation
\begin{document}
  \firstlinenum{1}
  \linenumincrement{1}
  \beginnumbering
  \pstart
    \bv{4}Baptizabat Ioannes in solitudine, et emendationis vitae baptisma publicabat ad peccatorum veniam,\bv{5} ad eumque proficiscebatur tota Iudaea regio ac Hierosolymitani, et ab eo baptizabantur omnes in Iordane fluvio, confitentes peccata sua.\bv{6} Erat autem Ioannes indutus camelinis pilis, lateribus pelliceo cingulo cinctis, vescebaturque locustis et \edtext{melle silvestri}{\Afootnote{quod mel Ioannes non in horto vel apiario colebat, sed in locis desertis inveniebat.}},\bv{7} atque huiusmodi verbis publice docebat: “Venit quidam post me, adeo me praestantior, ut ego non sim dignus qui eius calceorum corrigiam pronus solvam.\bv{8} Ego quidem vos aqua baptizavi, at is vos sancto Spiritu baptizabit.”
  \pend
  \endnumbering
\end{document}

Ps : in the actual version of reledmac handbook, the line number annotation mechanism is explained on § 9.10, in the new version, it is on § 5.4.6

  • Thanks! To add the line number reference to the footnote, is adding \linenum{|6} to the footnote the best solution? Also, the characters "om2" appear just above the document text, seemingly because of \usepackage{reledmac} and not anything in the document itself. (It disappears without reledmac.) Do you know what this is? – fvogel Jan 8 at 13:25
  • you want both verse number and line number? because now, with this code, I hide line number. But you don't need to add manually line number. And I don't see any "om2". Which version of reldmac do you use (maybe we can have this discussion by email, it would be simpler, you will finf my email on reledmac hanbdook) – Maïeul Jan 8 at 15:32
  • My mistake, I meant adding the verse number reference to the footnote. Currently I see a blank space before the lemma in the footnote. – fvogel Jan 8 at 16:30
  • 1
    ok, but you should contact miktex author for this bug of updating. – Maïeul Jan 11 at 22:23
  • 1
    please open a github issue, with a MWE. – Maïeul Jan 13 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.