0

I would like to try a package which seems interesting, but it some dependencies are not satisfied.

Here is my minimal example:

\documentclass{article}

\usepackage{pkgloader}
\LoadPackagesNow

\begin{document}
    pckloader trial
\end{document}

And I get the following error: ! LaTeX Error: File 'l3regex.sty' not found.. Therefore, I tried to update my distribution with the linux commands

tlmgr update --self
tlmgr update --all

But the package l3regex is still not foundable. Plus, my computer is not lying since l3regex.sty is not in my folder /texmf-dist/tex/latex/*.

So, is it something normal ? How can I workaround this problem ?

  • Write the package author, he should correct the package - l3regex is now part of expl3 and should no longer be loaded separately. – Ulrike Fischer Jan 7 at 14:09
  • Ok I will do that. – R. N Jan 7 at 14:24
  • 1
    I've logged github.com/mhelvens/latex-pkgloader/pull/25: there are also issues in withargs that need addressing ... – Joseph Wright Jan 7 at 15:19
  • l3regex is not longer experimental and therefore part of the l3kernel. Try to actualize the repository for your MikeTex distribution. – Aris Martin Accola Mar 19 at 10:02
5

Stand-alone l3regex was folded into the expl3 core some time ago. We've now withdrawn the 'stub' l3regex.sty file, so pkgloader needs to be updated. For the present, you could add

\usepackage{expl3}
\expandafter\def\csname ver@l3regex.sty\endcsname{}

before trying to load pkgloader to 'fool it' into thinking l3regex is loaded as a separate file.

  • 5
    That won't help. The package has more expl3 problems, e.g. quite a lot ! LaTeX3 Error: Variant form 'nncn'. – Ulrike Fischer Jan 7 at 14:12
  • @UlrikeFischer Ah, I'd just tried to solve the issue at hand ... – Joseph Wright Jan 7 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.