3

In a bilingual document, using babel, I want to have a dashed list when the main language is French, and a bullet list when the selected language is English.

Here is a MWE showing that switching to English does not typeset itemize lists as expected.

\documentclass[french]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage[a4paper]{geometry}
\usepackage[main=french,english]{babel}
\usepackage[autostyle]{csquotes}
\begin{document}
Cette partie du texte est composée en français avec :
\begin{itemize}
\item une liste ;
\item \enquote{à puces}.
\end{itemize}

\selectlanguage{english}
This part is in english with:
\begin{itemize}
\item a \enquote{bullet};
\item list.
\end{itemize}
\end{document}
  • The layout doesn't differ only in the labels, french also changes the spacing. So you should at first consider carefully, what exactly you want to restore at language changes. – Ulrike Fischer Jan 8 '19 at 9:41
  • I want to illustrate typographical differences between languages, and how to manage them with LaTeX. It seems the two can't be done at the same time in a simple way. – Jérôme Champavère Jan 8 '19 at 10:46
3

What about adding

\frenchsetup{GlobalLayoutFrench=false} 

in the preamble?

See all options available in the English documentation frenchb.pdf or in the French one frenchb-doc.pdf.

Both are part of the latest version of babel-french package on CTAN. You can also get them from http://daniel.flipo.free.fr/babel-french

  • 1
    @JouleV: I have added links in my answer. Thanks! – Daniel Flipo Mar 9 '19 at 10:11
  • This works as expected. Documentation says setting GlobalLayoutFrench to true changes lists and first paragraphs, but not the footnotes (command \StandardFootnotes can be used instead), when switching language. Are there other implications? – Jérôme Champavère Mar 11 '19 at 8:18
  • No, the documentation is correct: only footnotes' layout will not be affected. If you want to show both layouts (standard and French) in the same document for footnotes, you'll have to set flag \FBFrenchFootnotesfalse locally to display a standard footnote (French being the main language). – Daniel Flipo Mar 12 '19 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.