0

I'm using TextStudio to write a scientific article in English, and using its spell-checker and Languagetools.

The text is plenty of numbers using a dot as decimal separator, for example "34.12".

The spellcheck tool detects those dots as periods and suggests you to capitalize the next word.

It's not a serious problem but if the text contains thousands of number you need to spend a long time checking them in order to avoid missing real other errors.

Where in the settings can I change this behavior? How can I tell TexStudio those dots are part of the numbers and not ending sentences?

Another problem arises when My sentence starts with a Latex command, for example

\cref{fig4:fig1} shows the number of people...

will be properly rendered as

Figure 4 shows the number...

but the spell-checker is not aware of the insertion of the word "Figure" at the beginning of the sentence.

  • In the Option>Configure menu, try to check the Editor tab. Note that there is an advanced option to check and then you can see more tabs. In the Editor tab, you can hide some grammar errors in non textual. I'm not sure if this is your case, but lets try... – Sigur Jan 9 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.