0

I have the following code:

\documentclass[serif]{beamer}
\mode<presentation> {
  \usetheme{Warsaw}
  % \usecolortheme{lily}
}

\usepackage[minionint,mathlf,textlf]{MinionPro}
\renewcommand{\sfdefault}{Myriad-LF}
\usepackage{inconsolata}

\DeclareSymbolFont{missing}{OML}{cmr}{m}{n}
\DeclareMathSymbol{\ell}{\mathord}{missing}{'140}

\usepackage[absolute,overlay]{textpos}
\usepackage{graphicx}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\begin{document}

\begin{frame}
  \frametitle{Function}
  \begin{enumerate}
  \item[$\bullet$] This function
  \end{enumerate}
    \begin{align}
        A & = \dfrac{1}{a}\int\limits_{-a/2}^{a/2}g(t)dt,
    \end{align}
\end{frame}

\end{document}

which produces the following frame:

enter image description here

I do not know why the integral sign is strange, looking like an M or a W.

I found these warnings:

Class beamer Warning: ``serif'' is obsolete. Use font theme ``serif'' instead on input line 336. 

LaTeX Font Warning: Font shape 'TU/MinionPro-LF/m/n' undefined(Font) using 'TU/lmr/m/n' instead on input line 647. 

Package inputenc Warning: inputenc package ignored with utf8 based engines. 

LaTeX Font Warning: Some font shapes were not available, defaults substituted.
  • 2
    You're using the wrong font, apparently – Christian Hupfer Jan 11 at 15:41
  • I can't test because I don't have these special fonts, but try with \usefonttheme{professionalfonts} – samcarter Jan 11 at 15:42
  • 2
    The serif option is deprecated. The log file tells you what to use instead. – samcarter Jan 11 at 15:43
  • Do you find any error messages or warning in the log file? – samcarter Jan 11 at 15:44
  • I found these warnings : Class beamer Warning: ``serif'' is obsolete. Use font theme ``serif'' instead on input line 336. LaTeX Font Warning: Font shape 'TU/MinionPro-LF/m/n' undefined(Font) using 'TU/lmr/m/n' instead on input line 647. Package inputenc Warning: inputenc package ignored with utf8 based engines. LaTeX Font Warning: Some font shapes were not available, defaults substituted. – zdm Jan 11 at 15:47
2

Changing

\usepackage[minionint,mathlf,textlf]{MinionPro}

to

\usepackage[mathlf,textlf]{MinionPro}

solved the problem.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.