0

I have a document written in Russian. When I compile the document, the table of contents in the document itself is okay, but the cyrillic characters in the bookmarks are not properly encoded (Okular).

broken table of contents

If I export a document from Libre Office, everything is okay:

enter image description here

  • 2
    Welcome to TeX.SX. I guess you are using pdfTeX? You would have more luck with a unicode engine like XeTeX or LuaTeX. – Johannes_B Jan 12 at 7:12
  • If you load hyperref try adding the option pdfencoding=auto. – TeXnician Jan 12 at 7:30
  • The unicode option for hyperref makes bookmarks to be encoded correctly. – Sergei Golovan Jan 12 at 8:30
  • I'm using LuaLatex engine. – Vasile Lixcode Jan 12 at 9:36
  • @SergeiGolovan the unicode argument doesn't help. @TeXnician pdfencoding=auto helps me, thanks a lot! – Vasile Lixcode Jan 12 at 9:54
0

Pass hyperref the unicode option:

\documentclass{article}
\usepackage{fontspec}
\usepackage[unicode]{hyperref}
\usepackage{bookmark}

\setmainfont{Old Standard} % any font that supports Cyrillic

\begin{document}

\section{Азъ}

\subsection{Буки}

\subsection{Веди}

\section{Глаголи}

\subsection{Добро}

\subsection{Есть}

\end{document}

What I see with Adobe Acrobat Reader

enter image description here

Using bookmark is recommended, but not mandatory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.