2

A minimal example below

\documentclass{beamer}
\usepackage{animate}

\begin{document}
\frame{
  Hello, world.
}    
\end{document}

Gives me:

! Undefined control sequence.
<argument> ...g_pbs_bop_seq {##1}}\box_use_drop:N 
                                                  \@outputbox \hbox_overlap_...
l.7 }
  • 4
    That error suggests your expl3 version doesn't match animate: what TeX system do you have? – Joseph Wright Jan 13 '19 at 9:56
  • 3
    update your TeX system and try a again – user2478 Jan 13 '19 at 9:56
  • 4
    The example compiles without error for me. What versions of beamer, animate and expl3 are you using? I have beamer 2018/12/02 v3.55, animate.sty 2018/12/19 and expl3.sty 2019-01-01. You can find out your package versions easily if you add \listfiles to the start of your MWE file, the versions will then be listed in a convenient table in the .log file. – moewe Jan 13 '19 at 9:56
  • 4
    animate depends on expl3 via pdfbase.sty contained in media9. A full package update of the TeX distribution should fix everything. – AlexG Jan 13 '19 at 11:07
  • 4
    I'm voting to close this question as solved by update – user36296 Jan 14 '19 at 11:04
0

Oops, the TeX distribution was not up to date. Updating it solved the problem, sorry for polluting StackExchange with my silly question.

  • 1
    So, I think we can close this question. This is the standard procedure for problems that can be solved by package updates. – AlexG Jan 14 '19 at 11:03
  • (Don't feel offended by the close reason in the box below the question. It was automatically generated.) – AlexG Jan 14 '19 at 21:08
  • That's OK, my mistake – Arnaud Jan 15 '19 at 12:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.