1

I am having issues producing a PDF document from the TeX editor TeXstudio v2.12.14, with MiKTeX v2.9.6930 implementation. My operating system is the Linux Mint 18.3 Sylvia distribution. I was having no problems until today when I tried to compile a Tex document I have been working; I received the following message:

Could not Start Build & View:PdfLaTeX: pdflatex.exe -synctex=1 -interaction=nonstopmode.

When I check the LaTeX installation for TeXstudio, I receive the following message in a pop-up box:

Could not start:: pdflatex -version

When I check the latex version at the command line (i.e. latex -v), I get a segmentation fault. The System Report text file I receive after pressing the ok button for the TeXstudio check installation query returns the following, of which I have only included what I think is pertinent (with nothing about the pdflatex version):

which pdflatex: /home/smchartrand/bin/pdflatex

PDFLATEX: pdflatex -version

A Whole Bunch of Other Information...

TeXstudio: Path: /usr/bin/texstudio

Program call: texstudio

Setting file: /home/smchartrand/.config/texstudio/texstudio.ini

A Whole Bunch of Command Configuration Information...

At this point I am at a complete loss at how to proceed, and have spent the last four hours reading posts and trying to figure out the cause. Should I do a clean install of both MiKTeX and TeXstudio? Other suggestions or options. Thanks.

2
  • As a first try you can go to Options menu and configure the commands passing the full path to pdflatex: /home/smchartrand/bin/pdflatex
    – Sigur
    Jan 15, 2019 at 0:56
  • Thanks. I added the full path in quotes under the commands tab of the configuration menu option. Same outcome as presented above.
    – SurfProc
    Jan 15, 2019 at 1:02

2 Answers 2

0

I figured it out on my own, after following a couple different unrelated threads. First, I followed instructions (1) and (2a) here:

https://forums.linuxmint.com/viewtopic.php?t=170852

Then, I followed some posts to the following question:

install miktex for latex

The key element of this post is that MiKTeX is not commonly used on linux. TexLive is the more common TeX installation. So. I uninstalled MiKTeX and TeXstudio. Then I installed TexLive according to linux mint forum link posted above, and then I installed TeXstudio. Went with the default settings and everything worked perfectly. I hope this helps someone out there avoid serious frustration.

2
  • I installed TeXstudio via command line with the following commands: (1) sudo add-apt-repository ppa:sunderme/texstudio (2) sudo apt-get update and (3) sudo apt-get install texstudio. Those are all the details. Thanks Sigur for the suggestion.
    – SurfProc
    Jan 15, 2019 at 3:44
  • I should acknowledge that the above answer is a work around, and not and answer to the issue I posted. That remains unresolved and I welcome any other thoughts which people may offer up. This will be my last post unless someone else asks a question or suggests up a different resolution.
    – SurfProc
    Jan 15, 2019 at 4:31
0

Please check options in both texstudio and texmaker where command section where compilation aspects are given. There click latex+pdf. Please install both.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .