0

I am trying to cite "Alpaydın". In the bibliography it displays correctly, but when I use citations intext like \citep[3]{Alpaydin.2014} or \parencite[3]{Alpaydin.2014} it simply displays: "(Alpayd02n, 2014 S.3)"

The most confusing part is that when I am changing Alpayd{\i}n to Alpayd{`i}n, it displays the accented i everywhere correctly. Other special characters seem to work fine, too.

I appreciate the help!

I am using the following packages:

\usepackage{xstring}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{epigraph}
\usepackage[english, ngerman]{babel}   
\usepackage[
        backend=biber,  
        bibencoding=utf8,
        sortlocale=en_US,
        style=authoryear,
        natbib=true,
    ]{biblatex}

This is my bib-file:

@book{Alpaydin.2014,
 author = {Alpayd{\i}n, Ethem},
 year = {2014},
 title = {{Introduction to machine learning}},
 url = {http://site.ebrary.com/lib/alltitles/Doc?id=10919034},
 keywords = {Electronic books;Machine learning;Maschinelles Lernen},
 edition = {Third edition (Online-Ausg.)},
 publisher = {{The MIT Press}},
 isbn = {9780262325745},
 language = {eng},
 location = {Cambridge, Massachusetts and London, England},
 series = {{Adaptive computation and machine learning}},
  • 1
    If I add the missing closing curly bracket to the .bib entry and use the entry in a minimal example I get the expected output in both citations and the bibliography. The code shown so far is notg enough to reproduce exactly what you are seeing, especially because we don't know the definition/value of \zitierstil in style=\zitierstil,. Please follow tex.meta.stackexchange.com/q/228/35864 and tex.meta.stackexchange.com/q/4407/35864 to build a fully working self-contained example document. – moewe Jan 16 at 19:40
  • 1
    That said, while your entry should work as shown, I believe (as mentioned elsewhere), that the best solution™ is to use UTF-8 directly and write author = {Alpaydın, Ethem}, – moewe Jan 16 at 19:42
  • Sorry, I forgot to change \zitierstil for this post. I am using authoryear. I couldnt replicate my problem either... – feeder Jan 17 at 9:38
1

I found the cause of the problem. In my document structure I am importing my chapters like this via an iteration:

    \foreach \i in {01,02,03,04,05,06,07,08,09,...,99} {%
        \edef\FileName{content/\i kapitel}%
            \IfFileExists{\FileName}{%
                \input{\FileName}
            }
            {%
                %file does not exist
            }
    }

Because of the parameter \i in the iteration, the value of \i changed from the special character to 02 in chapter 2, 03 in chapter 3 etc.

Changing the parameter to \k solved the problem. Thank you for your help!

  • Note that \k will only work until you have to cite Zofia Stępień (Zofia St\k{e}pie\'{n}). Many one-letter commands are already taken by standard (La)TeX commands (often some kinds of accents) and should really not be redefined. It would be safer to do \newcommand*{\incchapnum}{} before the quoted code and then use \incchapnum instead of \i. The \newcommand throws an error if you overwrite an existing command. – moewe Jan 17 at 9:52
  • You may be able to streamline your code by using \InputIfFileExists{<file>}{<true>}{<false>} instead of \IfFileExists{<file>}{<true>\input{<file>}}{<false>}. In particular you would then only use the file name once. – moewe Jan 17 at 10:09
  • Thank you! That makes more sense. I'll improve it :) – feeder Jan 17 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.