0

I'm working with a document containing huge bibliography. That forced me to switch to lualatex, because pdflatex generated errors:

{\csname blx@nih@author\endcsname {{{hash=8ce87b4dc27b48d204336f9068c\ETC.
! TeX capacity exceeded, sorry [main memory size=5000000].
<argument> ...688a7851}{family={Kotam{ä}ki}, fami
                                              lyi={K\bibinitperiod }, gi...
l.202365       }            
!  ==> Fatal error occurred, no output PDF file produced!

The lualatex handled the file correctly, but then I needed to add a figure, which required use of pstool to replace a few placeholders with LaTeX processed text. Unfortunately, it seems that pstool calls pdflatex again, as I get the following in the figure-pstool.log:

This is pdfTeX, Version 3.14159265-2.6-1.40.19 (TeX Live 2019/dev/Debian (prelo
aded format=latex 2018.12.25)  16 JAN 2019 22:54
entering extended mode
[...]
{\csname blx@nih@author\endcsname {{{hash=8ce87b4dc27b48d204336f9068c\ETC.
! TeX capacity exceeded, sorry [main memory size=5000000].
<argument> ...iod }}}{{hash=dd6e000d600d547b04bd57
                                              d6485bc7bf}{family={Nogima...
l.202365       }

If you really absolutely need more capacity,
you can ask a wizard to enlarge me.

Is there any way to have pstool to call lualatex instead of pdflatex to avoid memory limitations?

  • 1
    pstool needs to call (dvi)latex to use psfrag but why is it having to process the bibliography? – David Carlisle Jan 16 at 23:06
  • anyway you always have the option of doing what pstool is automating, make a small document with just the image and the psfrag replacements process that with latex/dvips/ps2pdf to get a pdf file then just include that using graphics package in your main lualatex document – David Carlisle Jan 16 at 23:34
  • A few of those placeholders are supposed to be replaced by the bibliography references. – wzab Jan 16 at 23:35
  • ah:-).......... – David Carlisle Jan 16 at 23:35
  • 1
    I suppose you could try dvilualatex – David Carlisle Jan 16 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.