2

I'm working on overleaf v2.

I wrote :

\documentclass{article}
\usepackage[utf8]{inputenc} 
\usepackage[utf8]{inputenc}  % Accents codés dans la fonte
\usepackage[frenchb]{babel}  % Les traductions françaises
\usepackage{amsmath} 
\usepackage{graphicx}
\graphicspath{ {./images/} }
 \usepackage{amsfonts}
 \usepackage{biblatex}
\begin{document}
....
\begin{figure}
\centering
\includegraphics{comp_W_log.jpg}
\caption{\textit{On compare la fonction de Lambert à $\log(x)-1$ dans un certain interval}}
\label{fig:my_label}
\end{figure}
 ....
\end{document}

But I just get, after compiling : enter image description here

Can you help me plz ?

Edit: png didn't work either

  • 6
    (1) welcome, (2) always post full code, not sniplets. (3) It seems you have draft mode enabled, either as a class option or option to graphicx – daleif Jan 18 at 11:55
  • 2
    Unrelated to your problem, but better use \log instead of log – samcarter Jan 18 at 12:00
  • I don't know how exactly your image looks like, but from the caption I would guess that jpg is not a good file type for it. Better use a vector format like pdf or if you really have to use a pixelated format at least use png – samcarter Jan 18 at 12:02
  • 2
    Again unrelated to your problem, but don't load the same package multiple times and the option frenchb is deprecated, use french instead. For a French text it would probably also be good to load \usepackage[T1]{fontenc}. You probably want to give some floating specifier to your figure, e.g. \begin{figure}[htbp] for a better placement. And instead of manually changing the font family of your caption to italic, have a look at the caption package to make this automatically. – samcarter Jan 18 at 13:08
5

It looks like your editor could be set to 'draft mode' on Overleaf (this skips compiling images to render a PDF faster). You can turn it off on the dropdown menu on the Recompile button:

switch to 'normal mode' on recompile menu

Hope this does the trick, if you still see issues it could be worth writing to Overleaf support, at support@overleaf.com (I work there)

  • So in V2 we either get a fast autocompiler or an autocompiler that loads images, even though V1 could do both? – Melody Jan 21 at 8:44
  • @Melody Autocompile and fast mode can be turned on and off independently of each other, if that was the question? The standard compilation on v2 (with images rendered) is generally a bit faster than the same one on v1, but the caching of auxiliary files works a bit differently so some projects might be slower. If you're seeing a project compiling slower on v2 we should be able to help out if you write to us. On v1, the fast/draft setting also didn't show images. The setting is the same as passing the draft option to the documentclass. – walszje Jan 21 at 12:03
  • I'm seeing all my code compile a lot slower in V2 with the normal compile mode. I really wish I could still use V1, but it seems disabled now. At least I don't know how to access it. Maybe it's because I have a really long preamble? – Melody Jan 21 at 17:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.