PDF's corrupting / not opening when I compile them via Overleaf / LaTeX using XeLaTeX? Basically when I compile a file on overleaf.com using XeLaTex then say download on chrome browser onto my android device which runs Android OS 8.1.0, specifically downloading into the default download folder on either the MicroSD card OR internal storage (both tested) the file opens fine when in this folder. When I move the file outside this folder anywhere on the system the file then no longer opens. I have tried compiling the file (pdf) on my PC and directly transferring it as well as putting onto a cloud drive and downloading, all with the same negative result, the file no longer opens but it maintains its file size. I just need to move the PDF into a specific folder on my MicroSD card for a specific unimportant reason (relating to my work) and also to save space on internal storage. I have tested all the above with various other pdf files and they all work fine when I move them into a different folder. The reader I am using is an app called 'ReadEra' I have found no issues with this reader so far, I was having similar issues with all 'pdfs' on adobe acrobat user, but I don't seem to get any issues until now with 'ReadEra' specifically only pdf files compiled with XeLaTex engine, note again the file opens still if kept in the google download folder on the android device but not when moved or copier out of this folder onto my microsd card. I have also just given this a go with a different pdf file compiled with latex I think with pdfLaTeX engine, it seems to be a specific problem only with compiled files from LaTeX, a security issue perhaps? The error message it says when opening:

Title name of file "Unable to open the document, decoding error" /Directory name here which is usually my MicroSD card. I have also tested the file name I was using and a few other LaTeX compilers for the pdf's and the same issue, I have also tried to do a basic filename "test.pdf" with no effect as I thought underscores in the filenames might be causing an issue. Additionally I have checked security tabs in adobe reader in windows 10 on a working pdf on android compared to the non working file and I can't see any difference in them.


1 Answer 1


I think it is something to do with the files being read only or something on Android when you copy files internally on the device on the SD Card, basically what I find generally speaking with android devices, different PDF's tend to open differently in different apps, I have found so far that:

  • Mendeley: Opens any journal or academic paper with no ises
  • Kindle: opens most ebook files well
  • ReadEra: opens most downloaded pdf books well
  • Xodo: seems to solve my problems the most with opening pdf files, solved the above issue and pretty much opens any pdf file I throw at it despite where it comes from, how its compiled in Latex, where and how its moved on storage etc...
  • Adobe acrobat reader: Hardly opens most pdf files I throw at it, which is ironic.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .