1

When I compile the next code the micro sign doesn't shown:

\documentclass[12pt,twoside]{report}
\usepackage{amsmath,amsthm,amssymb,amsfonts}
\usepackage{color}
\usepackage{siunitx}
\pagestyle{empty}
\begin{document}
    \SI{100}{\micro\metre}

    $\SI{100}{\micro\metre}$
\end{document}

I also copied and tried to compile the code given in siunitx: µ doesn't work :

\documentclass{standalone}
\usepackage{fontspec}
\usepackage{siunitx}

% Note that the sign must be
%  µ
%  MICRO SIGN
%  Unicode: U+00B5, UTF-8: C2 B5
% and \emph{not}
%  μ
%  GREEK SMALL LETTER MU
%  Unicode: U+03BC, UTF-8: CE BC

\sisetup{math-micro=\text{µ},text-micro=µ}

\begin{document}
Now you can \si\micro\ all the things.
\end{document}

But I get a 'Fatal Package fontspec Error: fontspec package requires either XeTeX or LuaTex.'

I am using MikTex2.9.

What can be done??

  • 2
    Your first example works fine for me. Do you get any warnings in your log file about missing fonts? The second example needs to be compiled with xelatex or lualatex instead of pdflatex. – samcarter_is_at_topanswers.xyz Jan 21 '19 at 15:15
  • 2
    I have no issues with either. Are you sure your MikTeX is 100% up to date both as user and admin? I'm currently updating my TeXLive 2019, to see if there are newer stuff that is problematic, it will take a few minutes. Still no issues after full update. – daleif Jan 21 '19 at 15:17
  • The compilation results show 0 warnings, and I also didn't find warnings in the log file. I downloaded MikTex2.9 last week from the official site. – user4861528 Jan 21 '19 at 15:34
  • 1
    How did you look in the log? Actually at the log or the parsed stuff that your editor shows you? Might be an idea to post the log as well as the MWEs. SInce miktex does not use cm-super as default (TeXLive does), does adding the lmodern package do anything? – daleif Jan 21 '19 at 15:39
  • 3
    Just to debug in case others have this issue. Can you post the log for the original two MWEs without the use of lmodern. We'd like to know exactly what is going on as we have trouble recreating it. – daleif Jan 21 '19 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.