6

for a simple pscircle I get a mismatched radius for thicker line. The small red circle in the left picture shows the mismatch with linewidth=1pt. In the right picture the small green circle shows that there is no mismatch for linewidth=0.5pt. I already see this deviation in dvi (with yap) and also in ps and pdf file. Please see the following minimal example (compiled with latex.exe under miktex 64bit): minimal example

\documentclass{scrartcl}
\usepackage{pstricks}
\usepackage{pst-plot}

\begin{document}
\psset{unit=1.7cm}
\begin{center}
\begin{pspicture}(-1.3,-1.3)(2.0,1.45)%
\psaxes[labels=all,ticks=all,linewidth=1.0pt]{->}(0,0)(-1.3,-1.3)(1.3,1.3)[$Re\{z\}$,0][{$Im\{z\}$},0]%
\pscircle[linewidth=1pt](0.0,0.0){1.0}%<- problem is here
\pscircle[linewidth=1pt,linecolor=red](1,0.0){0.2}%
\rput[br]{0}(2.0,-1.3){linewidth=1pt}%
%\psframe[linewidth=0.5pt,linecolor=red](-1.3,-1.3)(2.0,1.45)% Frame of pspicture
\end{pspicture}%
%
\begin{pspicture}(-1.3,-1.3)(2.0,1.45)%
\psaxes[labels=all,ticks=all,linewidth=1.0pt]{->}(0,0)(-1.3,-1.3)(1.3,1.3)[$Re\{z\}$,0][{$Im\{z\}$},0]%
\pscircle[linewidth=0.5pt](0.0,0.0){1.0}%
\pscircle[linewidth=1pt,linecolor=green](1,0.0){0.2}%
\rput[br]{0}(2.0,-1.3){linewidth=0.5pt}%
%\psframe[linewidth=0.5pt,linecolor=red](-1.3,-1.3)(2.0,1.45)% Frame of pspicture
\end{pspicture}%
\end{center}
\end{document}
3

use

    \pscircle[linewidth=1pt,dimen=middle](0.0,0.0){1.0}%<- problem was here

Will be fixed in next upload to CTAN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.