1

I am using same format of .bib file entry, but get different output formats in beamer. Here is the MWE:

\documentclass{beamer}

\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}

%% Bibliography
\usepackage[backend=biber,style=alphabetic,citestyle=authoryear]{biblatex}
\bibliography{bibfile.bib}

\begin{document}

\begin{frame}{Trial frame}
\cite{Borzacchiello2017} \\
\cite{LEGUENNEC2018} \\
\cite{Goldfarb2014} \\
\end{frame}

\begin{frame}[allowframebreaks]{References}
    \printbibliography
\end{frame}

\end{document}

with the following .bib file entries:

@article{LEGUENNEC2018,
    author = "Le Guennec, Yves 
         and Brunet, Jean-Patrick 
         and Daim, Fatima Zohra 
         and Chau, Ming 
         and Tourbier, Yves",
    title = "A parametric and non-intrusive reduced order model of car crash simulation",
    journal = "Computer Methods in Applied Mechanics and Engineering",
    year = "2018",
}

@Article{Borzacchiello2017,
    author="Borzacchiello, Domenico
        and Aguado, Jos{\'e} V.
        and Chinesta, Francisco",
    title="Non-intrusive Sparse Subspace Learning for Parametrized Problems",
    journal="Archives of Computational Methods in Engineering",
    year = "2017",
}

@article{Goldfarb2014,
    author = "Goldfarb, Donald and Qin, Zhiwei",
    title = "Robust Low-Rank Tensor Recovery: Models and Algorithms",
    journal = "SIAM Journal on Matrix Analysis and Applications",
    year = "2014",
}

But I get the following output. As you can see the format is different in reference slide and citation as well:

enter image description here

I would like to have:

1) citation format : "FirstAuthor Year", preferably without "et. al"

2) Reference slide format: names of all authors, with first names abbreviated

11
  • 1
    Can you explicitly list what you'd like to change? Jan 23 '19 at 17:23
  • Check maxnames in the documentation. Jan 23 '19 at 17:24
  • 1
    It's not "inconsistent", it is a feature. biblatex controls, according to the number of authors, whether the list should be shortened or not. This is configurable. What is the behavior you'd like to obtain?
    – gusbrs
    Jan 23 '19 at 17:24
  • I would like the format "FirstAuthorName year", instead of "et al" in one place and list of authors in other. Also, for references, it would be cool if first names are abbreviated in references Jan 23 '19 at 17:25
  • 1
    Please, state clearly, in your question, what is the result you'd like to obtain. This can be controlled independently for citations and bibliography, if need be.
    – gusbrs
    Jan 23 '19 at 17:29
5

To control the namelists according to your specifications, biblatex's package options are enough. maxcitenames=1 will give citations with only the first author (regularly, with "et al."); maxbibnames=99 should be enough for normal cases to include all authors in the bibliography; giveninits=true will abbreviate given names throughout.

To remove the "et al." of shortened authors lists a simple solution is to redefine the corresponding localization string with:

\DefineBibliographyStrings{english}{andothers={}}

Indeed, since version 3.13, biblatex offers support to this procedure. In particular, you should use nohashothers=true when removing the "et al." string to allow biblatex to generate unique labels for your citations. You can also fine-tune sorting in this case with the option nosortothers.

I'm personally not keen on removing the "et al." string, and I don't recommend it, but a recent version of biblatex allows you to do so, if you really wish, in a consistent manner.

Note I have changed your style=alphabetic,citestyle=authoryear to style=authoryear. Mixing those styles, though technically "works", is bound to give you some inconsistencies or sub optimal results.

\documentclass{beamer}

\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}

\usepackage{filecontents}

\begin{filecontents}{bibfile.bib}
  @article{LEGUENNEC2018,
    author = "Le Guennec, Yves
              and Brunet, Jean-Patrick
              and Daim, Fatima Zohra
              and Chau, Ming
              and Tourbier, Yves",
    title = "A parametric and non-intrusive reduced order model of car crash simulation",
    journal = "Computer Methods in Applied Mechanics and Engineering",
    year = "2018",
  }

  @article{LEGUENNEC2018_2,
    author = "Le Guennec, Yves",
    title = "Study 2 by le Guennec",
    journal = "A journal title",
    year = "2018",
  }

  @Article{Borzacchiello2017,
    author="Borzacchiello, Domenico
            and Aguado, Jos{\'e} V.
            and Chinesta, Francisco",
    title="Non-intrusive Sparse Subspace Learning for Parametrized Problems",
    journal="Archives of Computational Methods in Engineering",
    year = "2017",
  }

  @article{Goldfarb2014,
    author = "Goldfarb, Donald and Qin, Zhiwei",
    title = "Robust Low-Rank Tensor Recovery: Models and Algorithms",
    journal = "SIAM Journal on Matrix Analysis and Applications",
    year = "2014",
  }
\end{filecontents}

\usepackage[
  style=authoryear,
  maxcitenames=1,
  maxbibnames=99,
  giveninits=true,
  nohashothers=true,
  nosortothers=true,
  ]{biblatex}

\addbibresource{bibfile.bib}

\DefineBibliographyStrings{english}{andothers={}}

\begin{document}

\begin{frame}{Trial frame}
  \cite{Borzacchiello2017}

  \cite{LEGUENNEC2018}

  \cite{LEGUENNEC2018_2}

  \cite{Goldfarb2014}
\end{frame}

\begin{frame}[allowframebreaks]{References}
  \printbibliography
\end{frame}

\end{document}

Resulting in citations:

enter image description here

and references:

enter image description here

9
  • Thank you! Works like a charm, but had to I include uniquename=init in one of the options to avoid warnings about conflicting options. Jan 23 '19 at 18:07
  • I opened a feature request to discuss ways to properly discard the "et al.": github.com/plk/biblatex/issues/861
    – moewe
    Jan 24 '19 at 9:42
  • @moewe I was aware of ext-authoryear-terse naturaly. Still, it is a different kind of "terse", ain't it?
    – gusbrs
    Jan 24 '19 at 10:41
  • 1
    Sure. but you know me, I can't let an opportunity to advertise biblatex-ext slide ;-)
    – moewe
    Jan 24 '19 at 10:44
  • @moewe Fair enough!
    – gusbrs
    Jan 24 '19 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.