4

Despite using advice from answers to the two questions (1) and (2), when I try to compile

\documentclass{standalone}
\usepackage{tikz}
\usetikzlibrary{decorations,calligraphy}

\begin{document}
  test
\end{document}

there are still many error messages. Is it possible to fix this in the document?

Edit:

I get the following errors:

spath3.sty:197: LaTeX3 Error: Variant form 'VnV' deprecated for base form '\spath_get:nnN'.
spath3.sty:197: LaTeX3 Error: Variant form 'nnV' deprecated for base form '\spath_get:nnN'.
tikzlibrarycalligraphy.code.tex:707: Undefined control sequence.
tikzlibrarycalligraphy.code.tex:707: You can't use `\mathchar"1' after \advance.
tikzlibrarycalligraphy.code.tex:707: You can't use `the letter :' after \the.

I use pdfTeX 3.14159265-2.6-1.40.19 (TeX Live 2018).

  • 2
    I haven't any errors on your code. What is, please, your LaTeX distribution? What's the mistake you get? Thank you. – Sebastiano Jan 24 at 12:49
  • 2
    good point, I added more info. – Deniz Jan 24 at 12:57
  • 2
    problem is in spath package which is used in caligraphy. Author of this package sent me (jan, 6) a new version of package which eliminate all problems. this new version should be now on ctan (i didn't check this). see tex.stackexchange.com/questions/442132/…, tex.stackexchange.com/questions/408378/…, tex.stackexchange.com/questions/468763/… – Zarko Jan 24 at 13:07
  • Unfortunately, the version on ctan is from 2016… – Deniz Jan 24 at 14:04
  • 2
    Did you try to download and install spath3 from this repository? This did the trick for me when writing this answer. I just checked, when not using the downloaded version but what comes with TeXLive I reproduce your error, but it disappears with the style file from the repository. – user121799 Jan 24 at 17:45
2

I encountered the same problem when writing this answer. And on my original TeXLive distribution I do reproduce your error messages. To fix it,

  1. Download the more recent version from this repository.
  2. Run tex spath3.dtx on the terminal.
  3. Copy the thus produced style file spath3.sty in the same directory where the TeX file you want to compile is.

This did the trick for me. (I'll be happy to remove this if it does not solve your problem or LoopSpace tells me to do so.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.