0

I'm using the following code to cite an URL,

 @manual{real_attacks,
    title={A Brief History of Car Hacking 2010 to the Present},
    note={[Online]. Available: \url{https://smart.gi-de.com/2017/08/brief-history-car-hacking-2010-present/}},
    year={2017}
}

but I get an extra comma instead of a dot ! enter image description here

Also the title is italic which shouldn't be.

\documentclass[10pt, twocolumn, twoside, journal]{IEEEtran}
    \usepackage{amsmath, amsfonts, amssymb, color, enumerate, amsthm, graphicx}
    \usepackage{tikz, subcaption, cite}
    \usepackage{color, xcolor, soul, bm}
    \PassOptionsToPackage{hyphens}{url}\usepackage{hyperref}
    \newtheorem{lemma}{Lemma}
    \begin{document}
        \begin{lemma}[\cite{Mieghem11}]\label{lem: max singular}
            This is my lemma ...
        \end{lemma}
    \bibliographystyle{IEEEtran}
    \bibliography{IEEEabrv,refs}
    \end{document}
  • There are several ways to produce bibliographies in LaTeX and the way you are using strongly influences if and how this can be changed. So before we can help you any further we must know which bibliography and citation packages you are loading (cite, natbib, biblatex, ...) and which style you are using (the argument of \bibliographystyle for BibTeX-based solutions or the value of the style option for biblatex). This is best shown in an MWE (see tex.meta.stackexchange.com/q/228/35864 tex.meta.stackexchange.com/q/4407/35864). – moewe Jan 25 at 9:13
  • @moewe Please see the updated question. – Mohammad Jan 25 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.