4

I'm writing a report in latex for school for several months and everything was fine. But recently out of nowhere it stopped compiling and give a lot errors like the following one:

! Missing } inserted.
<inserted text> 
                }
l.30 \begin{document}

I tried reinstalling the latex distrib but it's still failing.

Even by trying to compile a document without much inside it leads to the same error:

\documentclass[noposter,final]{polytech/polytech}

\schooldepartment{di}
\typereport{prddi5}
\reportyear{2018-2019}

\title{Title}
%\subtitle{}

\student{AAA}{BBB}{AAA.BBB@etu.univ-tours.fr}
\academicsupervisor{A}{B}{A.B@univ-tours.fr}
\academicsupervisor{AA}{BB}{AA.BB@univ-tours.fr}

\addbibresource{biblio.bib}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\resume{RE}
\motcle{MC}

\abstract{AB}
\keyword{KW}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\begin{document}
TEST
\end{document}

Seeing that this fails I suspect that it comes from the class polytech/polytech that we have to use (which sources are available here: https://gitlab.com/MrCraftCod/polytechlatex).

Now the thing is that I didn't modify these since the time it was working and now. Plus if I use overleaf with it it does work. So it must come from a package that have been updated and somehow messes up things.

Is there a way for me to narrow down the source of the problem?

Thank you for your help!

  • 1
    Hi, welcome on LaTeX.SE! Thanks for posting an example. Have you tried making it even more minimal to track down the issue? (E.g., removing \addbibresource, \resume, etc.) – ebosi Jan 25 at 11:49
  • This class definitely loads too much packages... It takes awfully long to compile this until the error occurs. – user31729 Jan 25 at 11:57
  • If I remove the bib file the same errors happens. Though I can't really remove the resume etc else the class will blow up to my face. – MrCraftCod Jan 25 at 11:58
  • @ChristianHupfer I do agree, a lot of things are not used. Though we don't really have a choice. – MrCraftCod Jan 25 at 11:58
  • Just looking at the GIT repository contents, somebody changed the main class file and two other style files 4 weeks ago. I guess they screwed something up then. Try contacting the author, or find out how to revert to the previous version. – alephzero Jan 25 at 11:59
3

Tabu package currently has some issues and the original author is out of contact, fixes are being developed at https://github.com/tabu-fixed but the internal documentation of the package is not that detailed.

Your example document works if you revert array, longtable and tabu to their texlive 2017 versions (just placing old copies of the packages in the same directory as the document).

That of course undoes the bug fixes that were made to array, but gets tabu back to a consistent state for now.

  • Indeed, removing the import of the package and commenting the longtabu part does make the compilation not fail. I'll see if I import older versions or try to rewrite this part in an other way. But thank you a lot to pinpoint what's the source cause. And thank you everyone that was involved and trying to help all along :) – MrCraftCod Jan 25 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.